HDOJ-----1175---连连看DFS

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
 

Input
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!
 

Output
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。
 

Sample Input
  
  
3 4 1 2 3 4 0 0 0 0 4 3 2 1 4 1 1 3 4 1 1 2 4 1 1 3 3 2 1 2 4 3 4 0 1 4 3 0 2 4 1 0 0 0 0 2 1 1 2 4 1 3 2 3 0 0
 

Sample Output
  
  
YES NO NO NO NO YES
迷宫问题,一般是搜索

注意转折次数的判断和不走回头路就好

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<set> 
#include<queue>
#include<vector>
#include<functional>
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CL(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
const int maxn = 1e3+10;
const int MOD = 1e9+7; 
int pos[maxn][maxn], res[maxn][maxn];
int m, n, a, b, x, y;
bool flag;
int dir[4][2] = {0, 1, 0, -1, 1, 0, -1, 0};
void dfs(int p, int q, int ans, int d){
	if(p < 1 || p > n || q < 1 || q > m) return ;
	if(ans > 2) return ;
	if(flag) return ;
	if(p == x && q == y){
		flag = true;
		return ;
	}
	if(pos[p][q]) return ;//这个判断要放在后边,因为终点不是0,放前边会错误返回找不到终点
	if(res[p][q] != -1 && res[p][q] <= ans) return ;//已走过的转折次数少于当前转折次数肯定错误
	res[p][q] = ans;
	for(int i = 0; i < 4; i++){
		if(d != i) dfs(p+dir[i][0], q+dir[i][1], ans+1, i);
		else dfs(p+dir[i][0], q+dir[i][1], ans, i);
	}
}
int main(){ 
    int t, kcase = 1;
    while(scanf("%d%d", &n, &m) == 2 && (n || m)){
    	for(int i = 1; i <= n; i++){
    		for(int j = 1; j <= m; j++) scanf("%d", &pos[i][j]);
		}
		scanf("%d", &t);
		while(t--){
			scanf("%d%d%d%d", &a, &b, &x, &y);
			CL(res, -1);
			flag = false;
			if((pos[a][b] != pos[x][y]) || !pos[a][b]){
				printf("NO\n");
				continue;
			}
			for(int i = 0; i < 4; i++){
				dfs(a+dir[i][0], b+dir[i][1], 0, i);
			}
			printf(flag ? "YES\n" : "NO\n");
		}
	}
    return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值