poj2115——C Looooops(数论,解模线性方程)

Description

A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C)

statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input
3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output
0
2
32766
FOREVER

基本算是《算法导论(第三版)》上的例题了,欧几里得扩展算法在p549,模线性方程的解法在p555。本体与书上不同的地方在于,书上是解ax=b(mod n)的所有解,而题目只需要最小的正整数输出,所以还需要用x=(x%(n/d)+n/d)%(n/d)来得出需要的那个解。

还有几个小技巧,2^k可以直接用1<

#include <iostream>
#include <cstdio>
using namespace std;
long long gcd(long long a,long long b,long long &x,long long &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    else
    {
        long long d=gcd(b,a%b,x,y);
        long long xx=x;
        x=y;
        y=xx-a/b*y;
        return d;
    }
}
int main()
{
    long long A,B,C,k,a,b,n,d,x,y;
    while(scanf("%I64d%I64d%I64d%I64d",&A,&B,&C,&k))
    {
        if(A==0&&C==0&&C==0&&k==0)
            break;
        a=C;
        b=B-A;
        n=1LL<<k;
        d=gcd(a,n,x,y);
        if(b%d==0)
        {
            x=x*(b/d)%n;
            x=(x%(n/d)+n/d)%(n/d);
            printf("%I64d\n",x);
        }
        else
            printf("FOREVER\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值