山东省第五届ACM省赛题——Weighted Median(模拟)

题目描述
For n elements x1, x2, …, xn with positive integer weights w1, w2, …, wn. The weighted median is the element xk satisfying
and , S indicates
Can you compute the weighted median in O(n) worst-case?

输入
There are several test cases. For each case, the first line contains one integer n(1 ≤  n ≤ 10^7) — the number of elements in the sequence. The following line contains n integer numbers xi (0 ≤ xi ≤ 10^9). The last line contains n integer numbers wi (0 < wi < 10^9).

输出
One line for each case, print a single integer number— the weighted median of the sequence.

示例输入
7
10 35 5 10 15 5 20
10 35 5 10 15 5 20
示例输出
20

本来看到n是10^7就想着是不是有什么高效的算法,结果一看别人做的才知道可以直接模拟过程,从1到n循环,结果700多MS过了。。。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#define MAXN 10000010
using namespace std;
struct Number
{
    int x,w;
};
Number num[MAXN];
bool cmp(Number a,Number b)
{
    return a.x<b.x;
}
long long sum,first,last,ans;
int main()
{
    double S;
    int n,m,i;
    while(~scanf("%d",&n))
    {
        sum=0;
        for(i=1; i<=n; ++i)
            scanf("%d",&num[i].x);
        for(i=1; i<=n; ++i)
        {
            scanf("%d",&num[i].w);
            sum+=num[i].w;
        }
        sort(num+1,num+1+n,cmp);
        S=sum*0.5;
        first=last=0;
        for(i=1;i<=n-1;++i)
        {
            first+=num[i].w;
            last=sum-first-num[i+1].w;
            if(first<S&&last<=S)
            {
                ans=num[i+1].x;
                break;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值