山东省第五届ACM省赛题——Painting Cottages(求点集的划分)

题目描述
The new cottage settlement is organized near the capital of Flatland. The construction company that is building the settlement has decided to paint some cottages pink and others — light blue. However, they cannot decide which cottages must be painted which color. The director of the company claims that the painting is nice if there is at least one pink cottage, at least one light blue cottage, and it is possible to draw a straight line in such a way that pink cottages are at one side of the line, and light blue cottages are at the other side of the line (and no cottage is on the line itself). The main architect objects that there are several possible nice paintings. Help them to find out how many different nice paintings are there.

输入
The first line of the input file contains n — the number of the cottages (1 ≤ n ≤ 300). The following n lines contain the coordinates of the cottages — each line contains two integer numbers xi and yi (−10^4 ≤ xi, yi ≤ 10^4).

输出
Output one integer number — the number of different nice paintings of the cottages.

示例输入
4
0 0
1 0
1 1
0 1
示例输出
12
提示
Sample.
这里写图片描述

可以把问题转化为求N个点可以组成多少不同的线段

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#define MAXN 10000010
using namespace std;
struct Node
{
    double x,y;
};
Node a[305];
map<pair<int,int>,int> H;
int gcd(int a,int b)
{
    if(b==0)
        return a;
    else
        return gcd(b,a%b);
}
int main()
{
    int n,cnt=0;
    while(~scanf("%d",&n))
    {
        cnt=0;
        for(int i=0; i<n; ++i)
            scanf("%lf%lf",&a[i].x,&a[i].y);
        for(int i=0; i<n; ++i)
        {
            H.clear();
            for(int j=i+1; j<n; ++j)
            {
                int aa=a[i].x-a[j].x;
                int bb=a[i].y-a[j].y;
                int cc=gcd(aa,bb);  //如果有三个点可以组成一条线段,可以用gcd+关联筛选
                if(H[make_pair(aa/cc,bb/cc)]==0)
                {
                    cnt++;
                    H[make_pair(aa/cc,bb/cc)]=1;
                }
            }
        }
        printf("%d\n",cnt*2);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值