hdu4283——You Are the One(区间dp)

Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?

Input
  The first line contains a single integer T, the number of test cases. For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)

Output
  For each test case, output the least summary of unhappiness .

Sample Input
2
  
5
1
2
3
4
5

5
5
4
3
2
2

Sample Output
Case #1: 20
Case #2: 24

对每个区间(类似于每个子串)进行dp,在区间[i,j]内,i可能第1个上场,也可能第j-i+1个上场,设第k个上场
那么区间就可分为[i,i+k-1]表示入栈过的队列,[i+k][j]为剩下的队列,因为i+k到j这些人的出场顺序增加了k,因此除了增加第i个人第k个上场的不愉快值,不愉快值还增加了k*(sum[j]-sum[i+k-1])

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#define MAXN 10000010
#define inf 1<<27
using namespace std;
int d[110],dp[110][110],sum[110];
int main()
{
    int t,n,cnt=1;
    scanf("%d",&t);
    while(t--)
    {
        sum[0]=0;
        scanf("%d",&n);
        for(int i=1; i<=n; ++i)
        {
            scanf("%d",&d[i]);
            sum[i]=sum[i-1]+d[i];
        }
        for(int i=1; i<=n; ++i)
            for(int j=i+1; j<=n; ++j)
                dp[i][j]=inf;
        for(int len=1; len<=n; ++len)
            for(int i=1; i+len<=n; ++i)
            {
                int j=i+len;
                for(int k=1; k<=j-i+1; ++k)
                    dp[i][j]=min(dp[i][j],dp[i+1][i+k-1]+d[i]*(k-1)+dp[i+k][j]+k*(sum[j]-sum[i+k-1]));
            }
        printf("Case #%d: %d\n",cnt++,dp[1][n]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值