hdu2072——单词数(STL,set)

22 篇文章 0 订阅
11 篇文章 0 订阅

Problem Description
lily的好朋友xiaoou333最近很空,他想了一件没有什么意义的事情,就是统计一篇文章里不同单词的总数。下面你的任务是帮助xiaoou333解决这个问题。

Input
有多组数据,每组一行,每组就是一篇小文章。每篇小文章都是由小写字母和空格组成,没有标点符号,遇到#时表示输入结束。

Output
每组只输出一个整数,其单独成行,该整数代表一篇文章里不同单词的总数。

Sample Input
you are my friend
#

Sample Output
4

set的用法

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <vector>
#include <iostream>
#include <set>
#include <cstring>
#include <string>
#define MAXN 1000010
#define inf 0xffffffff
using namespace std;
set<string> hehe;
int main()
{
    int j,cnt;
    string a,b;
    while(getline(cin,a))
    {
        j=0;
        cnt=0;
        if(a[0]=='#')
            break;
        int la=a.length();
        b="";
        for(int i=0; i<la; ++i)
        {
            if(a[i]!=' ')
            {
                b+=a[i];
                if(i==la-1)
                {
                    if(hehe.find(b)==hehe.end())
                    {
                        cnt++;
                        hehe.insert(b);
                    }
                }
            }
            else
            {
                j=0;
                if(b[0]>='a'&&b[0]<='z')
                {
                    if(hehe.find(b)==hehe.end())
                    {
                        cnt++;
                        hehe.insert(b);
                    }
                }
                b="";
            }
        }
        hehe.clear();
        printf("%d\n",cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值