Lightoj1259——Goldbach`s Conjecture(哥德巴赫猜想)

Description
Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input
Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1) Both a and b are prime
2) a + b = n
3) a ≤ b

Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1

自己的模板总是差那么多内存,换了一个就过了。。。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <map>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 10000005
#define mod 1000000007
using namespace std;
bool notprime[MAXN];
int primes[700005]; //素数从i=1开始
void get_prime()
{
    notprime[1]=true;
    for(int i=2;i<MAXN;++i)
    if(!notprime[i])
    {
        primes[++primes[0]]=i;
        for(long long j=(long long)i*i;j<MAXN;j+=i)
        notprime[j]=true;
    }
}
int main()
{
    get_prime();
    int t,cnt=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,ans=0;
        scanf("%d",&n);
        for(int i=1; primes[i]<=n/2; ++i)
            if(!notprime[n-primes[i]])
                ans++;
        printf("Case %d: %d\n",cnt++,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值