hdu5776——sum(抽屉原理)

Problem Description
Given a sequence, you’re asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO

Input
The first line of the input has an integer T (), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m (, ).
2.The second line contains n positive integers x () according to the sequence.

Output
Output T lines, each line print a YES or NO.

Sample Input
2
3 3
1 2 3
5 7
6 6 6 6 6

Sample Output
YES
NO

在bc上暴力过了,但杭电上超时,看了看解题报告才知道还要利用抽屉原理。
预处理前缀和,枚举两个前缀和算出差值就行。但根据抽屉原理,如果n大于等于m,就一定有符合条件的序列

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <map>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 100010
#define mod 1000000007
using namespace std;
int a[MAXN],sum[MAXN];
int main()
{
    int t,n,m,x;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);

        bool flag=false;
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&x);
            sum[i]=sum[i-1]+x;
        }
        if(n>=m)
        {
            printf("YES\n");
            continue;
        }
        for(int i=n;i>=0;--i)
            for(int j=i-1;j>=0;--j)
        {
            int tmp=sum[i]-sum[j];
            if(tmp%m==0)
            {
                flag=true;
                break;
            }
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值