poj3020——Antenna Placement(最小边覆盖)

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.
这里写图片描述
Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set [‘‘,’o’]. A ‘‘-character symbolises a point of interest, whereas a ‘o’-character represents open space.

Output

For each scenario, output the minimum number of antennas necessary to cover all ‘*’-entries in the scenario’s matrix, on a row of its own.
Sample Input

2
7 9
ooo**oooo
*oo*ooo
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*
Sample Output

17
5

之前一直想不通一点,为什么poj3041可以直接用x,y坐标作边集,而这个不行,想了很久才想了个让自己听得过去的想法,不一定正确。
poj3041最后的图是对整行或者整列操作,拥有相同x坐标或y坐标的点看成了相同的,但这里是对单独的点操作,考虑它周围的点是否能连成边,再看能不能覆盖掉,这是不同的地方。
因为处理后是无向图,注意得到的最大匹配是原图的两倍

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
//#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 505
#define Mod 10001
using namespace std;
int dx[]= {1,-1,0,0};
int dy[]= {0,0,1,-1};
int mp[MAXN][MAXN];
bool vis[MAXN];
int map[MAXN][MAXN],pre[MAXN],n;  //匹配路径;
int find(int cur)
{
    for(int i=1; i<=n; ++i)
    {
        if(!vis[i]&&map[cur][i])
        {
            vis[i] = true;
            if(pre[i] == 0 || find(pre[i]))
            {
                pre[i] = cur;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int h,w;
        scanf("%d%d",&h,&w);
        n=0;
        memset(mp,0,sizeof(mp));
        for(int i=1; i<=h; ++i)
            for(int j=1; j<=w; ++j)
            {
                char e;
                cin>>e;
                if(e=='*')
                    mp[i][j]=++n;
            }
        memset(map,0,sizeof(map));
        for(int i=1; i<=h; ++i)
            for(int j=1; j<=w;++j)
                if(mp[i][j])
                {
                    for(int k=0; k<4; ++k)
                    {
                        int x=i+dx[k],y=j+dy[k];
                        if(mp[x][y])
                            map[mp[i][j]][mp[x][y]]=1;
                    }
                }
        int ans=0;
        memset(pre,0,sizeof(pre));
        for(int i=1;i<=n;++i)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
                ans++;
        }
        printf("%d\n",n-ans/2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值