hdu5917——Wrestling Match(二分图染色)

Problem Description
Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is “good player”, the rest is “bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into “good player” and “bad player”.

Input
Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known “good players” and the number of known “bad players”.In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a “good player” number.The last line contains Y different numbers.Each number represents a known “bad player” number.Data guarantees there will not be a player number is a good player and also a bad player.

Output
If all the people can be divided into “good players” and “bad players”, output “YES”, otherwise output “NO”.

Sample Input
5 4 0 0
1 3
1 4
3 5
4 5
5 4 1 0
1 3
1 4
3 5
4 5
2

Sample Output
NO
YES

有n个选手的m场比赛,每次比赛都是好选手对抗坏选手,然后给出x个好选手的号码和y个坏选手的号码,求是否能把所有n个选手全部区分出来。
虽然题目中说了输入保证不会有一个人即是好选手也是坏选手,但还是要判断,并且之后给出的x,y个选手也并不是不会出场。。。。可以说很容易被题面坑。
之后就是二分图染色了,如果出现了染色的矛盾或者最后还有人没有人被染色的话,就都是错误的
据说光判断x==0&&y==0就能输出错误,但现在肯定不是这样

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#include <ctime>
#define INF 0x3f3f3f3f
#define MAXN 100005
#define Mod 1000000007
using namespace std;
int n,m,x,y;
struct Node
{
    int to,next;
};
Node edge[MAXN<<2];
int head[MAXN],vis[MAXN],e;
void add(int u,int v)
{
    edge[e].to=v;
    edge[e].next=head[u];
    head[u]=e;
    e++;
}
bool dfs(int v,int color)
{
    vis[v]=color;
    for(int i=head[v]; i!=-1; i=edge[i].next)
    {
        int u=edge[i].to;
        if(vis[u]==0)
        {
            if(color==1)
            {
                if(!dfs(u,2))
                    return false;
            }
            else if(color==2)
            {
                if(!dfs(u,1))
                    return false;
            }
        }
        else if(color==vis[u])
            return false;
    }
    return true;
}
int main()
{
    int u,v;
    while(~scanf("%d%d%d%d",&n,&m,&x,&y))
    {
        e=0;
        memset(head,-1,sizeof(head));
        memset(vis,-1,sizeof(vis));
        for(int i=0; i<m; ++i)
        {
            scanf("%d%d",&u,&v);
            add(u,v);
            add(v,u);
            vis[u]=0;
            vis[v]=0;
        }
        for(int i=0; i<x; ++i)
        {
            scanf("%d",&u);
            vis[u]=1;
        }
        for(int i=0; i<y; ++i)
        {
            scanf("%d",&u);
            vis[u]=2;
        }
        int flag=0;
        for(int i=1; i<=n; ++i)
        {
            if(vis[i]==1)
            {
                if(!dfs(i,1))
                {
                    printf("NO\n");
                    flag=1;
                    break;
                }
            }
            else if(vis[i]==2)
            {
                if(!dfs(i,2))
                {
                    printf("NO\n");
                    flag=1;
                    break;
                }
            }
        }
        if(flag)
            continue;
        for(int i=1; i<=n; ++i)
        {
            if(vis[i]==0)
            {
                if(!dfs(i,1))
                {
                    printf("NO\n");
                    flag=1;
                    break;
                }
            }
        }
        if(flag)
            continue;
        for(int i=1; i<=n; ++i)
        {
            if(vis[i]==-1||vis[i]==0)
            {
                printf("NO\n");
                flag=1;
                break;
            }
        }
        if(flag)
            continue;
        printf("YES\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值