acm Max Sum (diyidao)

C - Max Sum
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
 

Sample Input

     
     
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output

     
     
Case 1: 14 1 4 Case 2: 7 1 6

转一下别人的题解:
f[n]=max{f[n-1]+data[n],data[n]}另加起点,终点的记录。
下面模拟过程:
1.首先,读取第一个数据,令now和max等于第一个数据,初始化pos1,pos2,x位置
2.然后,读入第二个数据,判断
①. 若是now+temp<temp,表示当前读入的数据比之前存储的加上当前的还大,说明可以在当前另外开始记录,更新now=temp
②. 反之,则表示之前的数据和在增大,更新now=now+temp
3.之后,把now跟max做比较,更新或者不更新max的值,记录起始、末了位置
4.循环2~3步骤,直至读取数据完毕
代码:
#include<stdio.h>
int main()
{
	int t,n,now,p1,p2,x,j,max,temp;
	int k=1;
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		
		scanf("%d",&n);
		scanf("%d",&temp);
		now=max=temp;
		p1=p2=x=1;
		for(j=2;j<=n;j++)
		{
			scanf("%d",&temp);
			if(now+temp<temp)
			{
				now=temp;
				x=j;
			}
			else
				now+=temp;
			if(max<now)
			{
				max=now;
				p1=x;//起点由x固定 
				p2=j;//而终点是还没却定的,随j而变化的 
			}
		}
		printf("Case %d:\n%d %d %d\n",k++,max,p1,p2);
		if(i<t) //这里要注意下,最后一组数据后没有空格\n.
			printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值