杭电acm1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 265910    Accepted Submission(s): 63244


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2:

7 1 6

贪心问题,计算最大子序列,计算以每个节点为终点的最大子序列,若前一个节点最大子序列和为负则当前节点最大子序列和为其本身,否则当前节点加上前一节点的最大子序列和

/**
 * date:2017.11.18
 * author:孟小德
 * function:杭电acm1003
 *  Max Sum     贪心算法,计算每一个点做为终点的最大子序列和
 */



import java.util.*;

public class acm1003
{
    public static void main(String[] args)
    {
        Scanner input = new Scanner(System.in);

        int T = input.nextInt();

        for (int i=0;i<T;i++)
        {
            int N = input.nextInt();

            int[] num_N = new int[N];
            // 输入数列
            for (int j=0;j<N;j++)
            {
                num_N[j] = input.nextInt();
            }

            int[][] result = new int[N+1][3];
            result[0][0] = num_N[0];
            result[0][1] = 1;
            result[0][2] = 1;
            result[N][0] = num_N[0];
            result[N][1] = 1;
            result[N][2] = 1;
            for (int j=1;j<N;j++)
            {
                if (result[j-1][0] < 0)
                {
                    result[j][0] = num_N[j];
                    result[j][1] = j+1;
                    result[j][2] = j+1;

                }
                else
                {
                    result[j][0] = result[j-1][0] + num_N[j];
                    result[j][1] = result[j-1][1];
                    result[j][2] = j+1;
                }
                if (result[N][0] <= result[j][0])
                {
                    result[N][0] = result[j][0];
                    result[N][1] = result[j][1];
                    result[N][2] = result[j][2];
                }
            }
            System.out.println("Case " + (i+1) + ":");
            System.out.println(result[N][0] + " " +result[N][1]
                + " " + result[N][2]);
            if (i<T-1)
            {
                System.out.println();
            }
        }

    }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值