HDU1116 Play on Words 【欧拉图】+【并查集】

Play on Words

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5736    Accepted Submission(s): 1897


Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
 

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.
 

Source
 

经典题。
题意:给出N个字符串,当一个字符串的末尾单词跟另一个字符串的首单词相等时,这两个字符串可以首尾连接。问是否存在一种方案使得这些字符串连成一个序列。

题解:比赛时破天荒的往SPFA松弛最长路径上想去了,结果在构图上纠结了很久,反而把以前学过的欧拉图忘得精光,阿西吧,好在这道题算是复习了一下并查集和欧拉图。无向欧拉图:在图联通的情况下所有点的度为偶数或者有且只有两个点的度为奇数。有向欧拉图:在图联通的情况下所有的点入度等于出度,或者只有一个点入度比出度大1同时只有一个点入度比出度小1,不得出现入度跟出度绝对值大于1的点。

#include <stdio.h>
#include <string.h>

#define maxn 28

int pre[maxn], vis[maxn], in[maxn], out[maxn];
char str[1002];

int abs(int k) { return k < 0 ? -k : k; }

int ufind(int k) {
	int a = k, b;
	while(pre[k] != -1) k = pre[k];
	while(a != k) {
		b = pre[a];
		pre[a] = k;
		a = b;
	}
	return k;
}

bool unite(int a, int b) {
	a = ufind(a);
	b = ufind(b);
	if(a == b) return false;
	else {
		pre[a] = b;
		return true;
	}
}

int main() {
	int T, N, i, j, flag1, flag2, cnt, a, b;
	scanf("%d", &T);
	while(T--) {
		scanf("%d", &N);
		memset(pre, -1, sizeof(pre));
		memset(vis, 0, sizeof(vis));
		memset(in, 0, sizeof(in));
		memset(out, 0, sizeof(out));
		cnt = flag1 = flag2 = 0;
		while(N--) {
			scanf("%s", str);
			a = *str - 'a';
			b = str[strlen(str)-1] - 'a';
			if(!vis[a]) {
				vis[a] = 1; ++cnt;
			}
			if(!vis[b]) {
				vis[b] = 1; ++cnt;
			}
			++out[a]; ++in[b];
			if(unite(a, b)) --cnt;
		}
		if(cnt != 1) { // 森林
			printf("The door cannot be opened.\n");
		} else {
			for(i = 0; i < 26; ++i) {
				if(in[i] + 1 == out[i])
					++flag1;
				else if(out[i] + 1 == in[i])
					++flag2;
				else if(abs(in[i] - out[i]) > 1)
					break;
			}
			if(i < 26) printf("The door cannot be opened.\n");
			else if(!flag1 && !flag2 || flag1 == 1 && flag2 == 1)
				printf("Ordering is possible.\n");
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值