hdoj 5666 Segment (大数取模)(俄罗斯乘法)

Segment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1532    Accepted Submission(s): 564


Problem Description
     Silen August does not like to talk with others.She like to find some interesting problems.

     Today she finds an interesting problem.She finds a segment x+y=q .The segment intersect the axis and produce a delta.She links some line between (0,0) and the node on the segment whose coordinate are integers.

     Please calculate how many nodes are in the delta and not on the segments,output answer mod P.
 

Input
     First line has a number,T,means testcase number.

     Then,each line has two integers q,P.

    q is a prime number,and 2q1018,1P1018,1T10.
 

Output
     Output 1 number to each testcase,answer mod P.
 

Sample Input
  
  
1 2 107
 

Sample Output
  
  
0
 题意:x+y==p,直线与x,y坐标围成三角形中整数坐标的点的个数,不算直线上的点。
题解:推导公式:(p-1)*(p-2)/2  %p,  数据大,超long long ,有个俄罗斯乘法 可以快速相乘,(要 保证 除以2 的数是奇数
俄罗斯乘法是一种计算两数相乘的算法。
举例如下:
计算 35*72
过程
35 72
17 144
8 288
4 576
2 1152
1 2304
从上到下,对每一行,若左边的数字若为奇数,则将右边的数字取出,累加。
72+144+2304=2520
累加的结果2520即为乘积。
因为该算法不需要已知九九乘法表。
所以在计算机中有应用。
代码:
#include<cstdio>
#define LL long long
LL sum;
LL multi(LL a,LL b,LL p)
{
	sum=0;
	while(b)
	{
		if(b&1)
		{
			sum+=a;
			sum%=p;
		}
		a=a*2;
		a%=p;
		b>>=1;
	}
	return sum;
}
int main()
{
	int t;
	LL q,p,a,b;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld%lld",&q,&p);
		a=q-1;
		b=q-2;
		if(a%2)			//保证 除以2 的数是奇数 
			printf("%lld\n",multi(b/2,a,p));
		else
			printf("%lld\n",multi(a/2,b,p));
		
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值