hdoj 5666 Segment ( 数学几何 +快速积)

Segment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1756    Accepted Submission(s): 647


Problem Description
     Silen August does not like to talk with others.She like to find some interesting problems.

     Today she finds an interesting problem.She finds a segment  x+y=q .The segment intersect the axis and produce a delta.She links some line between  (0,0)  and the node on the segment whose coordinate are integers.

     Please calculate how many nodes are in the delta and not on the segments,output answer mod P.
 

Input
     First line has a number,T,means testcase number.

     Then,each line has two integers q,P.

    q  is a prime number,and  2q1018,1P1018,1T10.
 

Output
     Output 1 number to each testcase,answer mod P.
 

Sample Input
  
  
1 2 107
 

Sample Output
  
  
0

题意:给出一个直线方程x+y=q;给出q,在原点(0,0)到直线上的整数点坐标连线,问在两个坐标轴与方程直线中不在连线上的整数点坐标有多少,结果对p取模

思路:看了别人的讲解,用到线段上的整数坐标个数公式:gcd(|x1-x2|,|y1-y2|)-1;推导公式似懂非懂的,这有链接点击打开链接,最后推导为点的个数是:((q-1)*(q-2)/2)%p

直接取模,直接超时,后来才知道用有快速积 边加边取模,快速积大致可以理解为 拆分:(a+ a*2 * (b/2)); 当b为奇数时 运算加法取模 ;为偶数计算 除法和乘法取模,


code

#include <iostream>
#include<cstdio>
#define LL long long
using namespace std;

int main()
{
    int t;
    LL p,q;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld",&q,&p);
        LL a=q-1,b=q-2;
        if(a%2==0)
            a=a/2;
        else
            b=b/2;
            /****快速积******/
        LL ans=0;
        while(b)
        {
            if(b&1)
                ans=(ans+a)%p;
            b/=2;
            a=(a+a)%p;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值