hdu1498 大水题

Description

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.


Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".

Sample Input 

1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0

Sample Output

-1
1
2
1 2 3 4 5
-1

尽管是大水题  但是再怎么说就是自己走过的路啊  
不过现在只是二分图入门阶段   到现在为止接触的一些题目真的是太水了    只要    吧题目理解      套个模板就好了  所以这里就只拿一个hdu1498作为水题典例

简单说   题目是个最小点覆盖问题   二分图的最小点覆盖==最大匹配数     问的是哪些数字在k步操作内无法完全覆盖      也就是说最大匹配大于k的有哪些

ac code

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <set>
#include <iterator>

using namespace std;
const int maxn=105;
int n,k;
int g[maxn][maxn],link[maxn];
bool vis[maxn];
set<int> kao;
int hungary(int);
bool dfs(int,int);

int main()
{
    int temp,ans[maxn];
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(n==0&&k==0) break;
        kao.clear();
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&temp);
                kao.insert(temp);
                g[i][j]=temp;
            }
        int num=0,kase=0;
        for(set<int>::iterator it=kao.begin(); it!=kao.end(); it++)
        {
            temp=hungary(*it);
            if(temp>k) ans[num++]=*it;
        }
        if(num==0) printf("-1");
        else
        {
            sort(ans,ans+num);
            for(int i=0; i<num; i++)
            {
                if(kase++) putchar(' ');
                printf("%d",ans[i]);
            }
        }
        puts("");
    }
    return 0;
}
int hungary(int key)
{
    int num=0;
    for(int i=1; i<=n; i++) link[i]=-1;
    memset(link,-1,sizeof link);
    for(int i=1; i<=n; i++)
    {
        memset(vis,false,sizeof vis);
        if(dfs(i,key)) num++;
    }
    return num;
}

bool dfs(int x,int key)
{
    for(int i=1; i<=n; i++)
        if(!vis[i]&&g[x][i]==key)
        {
            vis[i]=true;
            if(link[i]==-1||dfs(link[i],key))
            {
                link[i]=x;
                return true;
            }
        }
    return false;
}

关于二分图的话    有一些性质是必须知道的
1.最小路径覆盖==  总顶点数 - 最大匹配数
2.最小点覆盖==最大匹配数
3.最大独立集==总节点数-最大匹配数






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值