poj 3041 Asteroids (最小点覆盖)

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20896 Accepted: 11346

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
题解:给出矩阵,要最小步骤消灭所有‘X’,每次可以消灭一行或者一列。
最小点覆盖:选择一个点就相当于覆盖了所有以它为端点的边,选择最少的点覆盖所有的边
利用二分图最大匹配的König定理:最小点覆盖数=最大匹配数
题目:行坐标和列坐标看做两个不相交的集合,进行建图。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
bool map[510][510];
bool vis[510];
int match[510];
int v1,v2;
int dfs(int x)
{
    for(int i=1;i<=v2;i++)
    {
        if(map[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(!match[i]||dfs(match[i]))
            {
                match[i]=x;
                return true;
            }
        }
    }
    return false;
}
int cnt()
{
    int ans=0;
    for(int i=1;i<=v1;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))
            ans++;
    }
    return ans;
}
int main()
{
    int n,k,x,y;
    scanf("%d%d",&n,&k);
    v1=v2=n;
    memset(map,0,sizeof(map));
    memset(match,0,sizeof(match));
    for(int i=1;i<=k;i++)
    {
        scanf("%d%d",&x,&y);
        map[x][y]=1;
    }
    int ans=cnt();
    printf("%d\n",ans);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值