hdu 1659——Bus System(Floyd)

Problem Description

Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

 

 

Input

The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

 

 

Output

For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

 

 

Sample Input

2

1 2 3 4 1 3 5 7

4 2

1

2

3

4

1 4

4 1

1 2 3 4 1 3 5 7

4 1

1

2

3

10

1 4

 

 

Sample Output

Case 1:

The minimum cost between station 1 and station 4 is 3.

The minimum cost between station 4 and station 1 is 3.

Case 2:

Station 1 and station 4 are not attainable.

 

 

Source

2008 “Sunline Cup” National Invitational Contest

 

题意:讲的一个公交系统,该系统通过起点和终点的距离进行收费,然后给出四个不同的lc,然后是路径,然后m次询问,对于每次询问输出最小的花费!

 

思路:因为询问有多组,所以自然想到用Floyd,在n个路径确定以后,根据表中的l让他映射到不同的价格,最后用Floyd处理即可!(注意:因为数据很大,图要用long long 保存)

 

Code

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

typedef long long ll;
const int N=110;
const ll INF=0x7fffffffffffffff; //此处也要注意
ll mp[N][N];
ll l[8],c[8];
int n,m;

void Floyd()
{
int i,j,k;
for (k=0;k<n;k++)
for (i=0;i<n;i++)
for (j=0;j<n;j++)
if (mp[i][k]<INF&&mp[k][j]<INF)
mp[i][j]=min(mp[i][k]+mp[k][j],mp[i][j]);
}

int main()
{
int T,ca;
int i,j,k;
scanf("%d",&T);
for (ca=1;ca<=T;ca++)
{
for (i=0;i<4;i++)
cin>>l[i];
for (i=0;i<4;i++)
cin>>c[i];
scanf("%d%d",&n,&m);
for( i=0;i<n;i++)
for(j=0;j<n;j++)
mp[i][j]= (i==j?0:INF);
int x[N];
for (i=0;i<n;i++)
scanf("%d",&x[i]);
for (i=0;i<n;i++)
for (j=i+1;j<n;j++)
{
for (k=0;k<4;k++)
{
if (abs(x[i]-x[j])<=l[k])
{
mp[i][j]=mp[j][i]=c[k];
k=0;
break;
}
}
if (k>=4) mp[i][j]=mp[j][i]=INF;
}
Floyd();
//cout<<mp[0][3]<<endl;
printf("Case %d:\n",ca);
while (m--)
{
int u,v;
scanf("%d%d",&u,&v);
if (mp[u-1][v-1]==INF) printf("Station %d and station %d are not attainable.\n",u,v);
else printf("The minimum cost between station %d and station %d is %lld.\n",u,v,mp[u-1][v-1]);
}

}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值