POJ 1631 Bridging signals

Bridging signals
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6001 Accepted: 3285

Description

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task? 

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number specifies which port on the right side should be connected to the i:th port on the left side.Two signals cross if and only if the straight lines connecting the two ports of each pair do.

Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6

Sample Output

3
9
1
4

Source

 

/*

http://acm.pku.edu.cn/JudgeOnline/problem?id=1631
DP+二分查找
一开始没有使用二分查找,时间复杂度是n ^ 2,结果超时
后来改用二分,时间复杂度是nlgn,AC
二分的思路是:
使用bsVal来保存当前长度的序列中最小的point位置
比如bsVal[2] = 3意味着,长度为二的序列中最小的位置是3
*/

#include <iostream>
#define maxv(a, b) ((a) >= (b) ? (a) : (b))
#define MAX_N 40000
using namespace std;

int maxData[MAX_N + 1];
int input[MAX_N + 1];
int maxP;
int bsVal[MAX_N + 1];

void binarySearch(int curPos)
{
    int l = 1, r = maxP, mid;
    while(l <= r)
    {
        mid = (l + r) / 2;
        if(bsVal[mid] < input[curPos])
            l = mid + 1;
        else
            r = mid - 1;
    }
    maxData[curPos] = l;
    bsVal[l] = input[curPos];
    maxP = maxv(maxP, l);
}
int main()
{
    int caseNum, pNum, i, j;
    scanf("%d", &caseNum);
    for(i = 1; i <= caseNum; i++)
    {
        maxP = 1;
        scanf("%d", &pNum);
        for(j = 1; j <= pNum; j++)
        {
            scanf("%d", &input[j]);
            maxData[j] = 1;
            if(j == 1)
            {
                bsVal[1] = input[j];
                continue;
            }
            binarySearch(j);
        }
        printf("%d/n", maxP);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值