寒假训练营之并查集:The Suspects

The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy isto separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Studentsin the same group intercommunicate with each other frequently, and a student may join several groups.
To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all studentgroups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a
suspect. Your job is to write a program which finds all the suspects.


Input


The input file contains several cases. Each test case begins with two integers n and m in a line, where
n is the number of students, and m is the number of groups. You may assume that 0 < n ≤ 30000 and
0 ≤ m ≤ 500. Every student is numbered by a unique integer between 0 and n−1, and initially student
0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one
line per group. Each line begins with an integer k by itself representing the number of members in the
group. Following the number of members, there are k integers representing the students in this group.
All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.


Output


For each case, output the number of suspects in one line.


Sample Input


100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0


Sample Output


4
1
1

这是我看资料的一道例题,其中解法是这么说的:**最基础的并查集,把所有可疑的都并一 块。**我就想说对于小白的我真的是难为我了,哈哈哈。
题解:就像资料上的解法一样,运用并查集即可,将所有可疑的都放在一个数组中。其实我现在还稀里糊涂的。。。。

代码如下:

#include<iostream>
#include<cstdio>
int n,m,k;
int parent[30010];
int total[30010];     //total[getParent(a)]是a所在的 group的人数 
using namespace std;
int getParent(int a)    //获取a的根,并把a的父节点改为根
{
    if(parent[a]!=a)
        parent[a]=getParent(parent[a]);
    return parent[a];
}
void merge(int a,int b)
{
    int p1=getParent(a);
    int p2=getParent(b);
    if(p1==p2)
        return;
    total[p1]+=total[p2];
    parent[p2]=p1;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        for(int i=0;i<n;i++)
        {
            parent[i]=i;
            total[i]=1;
        }
        for(int i=0;i<m;i++)
        {
            int h,s;
            scanf("%d",&k);
            scanf("%d",&h);
            for(int j=1;j<k;j++)
            {
                scanf("%d",&s);
                merge(h,s);
            }
        }
        printf("%d\n",total[getParent(0)]);
    }
    return 0;
}

小白心得

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值