用并查集找出病源

例题是: poj-1611

  这是一道关于疫情的题,非常适合出现在这个时候....

原题是:

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题目大意:SARS病毒很容易传染,在一所学校要找被感染了病毒的嫌疑人,如果一个组里面有一个人被感染,该组的所有人就                      会被确定为嫌疑人,而一个人可以在不同的组里面,现在默认是0号同学为嫌疑人,让找出所有的嫌疑人。

输入: n: 学生数量  m: 有几组

输出:嫌疑人数量

code:

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn = 30005;

int n,m;
int pre[maxn];

void init()
{
	for(int i=0 ; i<n ; i++)
	 pre[i] = i;
}

int find(int x){
	
	int r = x,t;
	while(x!=pre[x])
       x = pre[x];
	while(r!=x){   "这部分是剪枝
	   t=pre[r];
	   pre[r] = x;
	   r=t;		
	}
    return  x;
}

void join(int x, int y)
{
	int fx=find(x), fy=find(y);
	if(fx!=fy)
	   pre[fx] = fy;
}

int main()
{
	int k;
	while(~scanf("%d%d",&n,&m)&&(n+m))
	{
		init();
		while(m--){
			cin>>k;
			int temp = 0,t,f=1;
			for(int i=0; i<k; i++){
             	 scanf("%d",&t);
             	 if(f)
             	 {
        	 	    f=0;
             	 }else{
             	 	join(temp,t);
             	 }             	 
             	 temp = t;
			}
        
		}
		int res = 0;
		for(int i=0;i <n ;i++)
		{
			if(find(i) == find(0))
			 res++;
		}
		printf("%d\n",res);
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Gong JX

多谢鼓励

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值