A + B Problem II

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:

思路:从末尾开始加起,但是由与两个数的长度可能不同,末尾对应的下标会不同,计算的时候不方便,我们可以先将两个数倒置再相加,如:
     6451564 +
1234567896514
倒置后变成
4651546 +
4156987654321
这样末尾的下标相同,计算起来更加方便,最后再将计算结果倒着输出即可。

#include <stdio.h>
#include <string.h>

char num1[10005];
char num2[10005];
int ans[10005];//保存计算结果 

void invert(char a[], int len)//倒置功能 
{
    char temp;
    for (int i = 0; i <= len/2-1; i++)
    {
        temp = a[i];
        a[i] = a[len-i-1];
        a[len-i-1] = temp;
    }
}

int main()
{
    int t,count = 0;
    scanf("%d",&t);

    while (t--)
    {
        count++;
        scanf("%s%s",num1,num2);
        int len1 = strlen(num1);
        int len2 = strlen(num2);
        int lenmax = len1 > len2 ? len1 : len2;
        int lenmin = len1 < len2 ? len1 : len2;

        invert(num1,len1);//倒置两个数 
        invert(num2,len2);


        int flag = 0;//保存进位 
        for (int i = 0; i < lenmax; i++)
        {
            if (i < lenmin)
            {
                ans[i] = (num1[i]+num2[i]-'0'-'0'+flag)%10;
                flag = (num1[i]+num2[i]-'0'-'0'+flag)/10;
            }
            else
            {
                if (len1 > len2) 
                {
                    ans[i] = (num1[i]-'0'+flag)%10;
                    flag = (num1[i]-'0'+flag)/10;
                }
                else
                {
                    ans[i] = (num2[i]-'0'+flag)%10;
                    flag = (num2[i]-'0'+flag)/10;
                }
            }
        }
        if (flag != 0)
        {
            ans[lenmax] = flag;
            lenmax++;
        }
        if (count > 1) printf("\n");
        printf("Case %d:\n",count);

        invert(num1,len1);//将两个数倒置回来 
        invert(num2,len2);

        printf("%s + %s = ",num1,num2);
        for (int i = lenmax-1; i >= 0; i--)
        {
            printf("%d",ans[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值