Monkey Tradition

In ‘MonkeyLand’, there is a traditional game called “Bamboo Climbing”. The rules of the game are as follows:
1) There are N monkeys who play this game and there are N bamboos of equal heights. Let the height be L meters.
2) Each monkey stands in front of a bamboo and every monkey is assigned a different bamboo.
3) When the whistle is blown, the monkeys start climbing the bamboos and they are not allowed to jump to a different bamboo throughout the game.
4) Since they are monkeys, they usually climb by jumping. And in each jump, the ith monkey can jump exactly pi meters (pi is a prime). After a while when a monkey finds that he cannot jump because one more jump may get him out of the bamboo, he reports the remaining length ri that he is not able to cover.
5) And before the game, each monkey is assigned a distinct pi.
6) The monkey, who has the lowest ri, wins.
Now, the organizers have found all the information of the game last year, but unluckily they haven’t found the height of the bamboo. To be more exact, they know N, all pi and corresponding ri, but not L. So, you came forward and found the task challenging and so, you want to find L, from the given information.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 12). Each of the next n lines contains two integers pi (1 < pi < 40, pi is a prime) and ri (0 < ri < pi). All pi will be distinct.

Output
For each case, print the case number and the minimum possible value of L that satisfies the above conditions. If there is no solution, print ‘Impossible’.

Sample Input
2
3
5 4
7 6
11 3
4
2 1
3 2
5 3
7 1

Sample Output
Case 1: 69
Case 2: 113

新学技能:中国剩余定理

虽然没看懂网上题解的代码,但是按照博客里的思路敲了一下AC了
ps:博客里说到的“以n1为例,并非从5和7的公倍数中直接找一个除以3余2的数,而是先找一个除以3余1的数,再乘以2。”,没理解为什么要这样处理。。感觉并没有优化。。,我写的代码里也没有这样处理

#include <stdio.h>

int p[15];
int r[15];
int temp[15];

long long crt(int i,long long sum)
{
    sum = sum / p[i];
    for (long long j = sum; 1; j+=sum)
    {
        if (j % p[i] == r[i])
        {
            return j;
        }
    }
}

int main()
{
    int t,first = 0;
    scanf("%d",&t);

    while (t--)
    {
        first++;
        int n;
        long long ans = 0;
        scanf("%d",&n);
        long long sum = 1;
        for (int i = 1; i <= n; i++)
        {
            scanf("%d%d",&p[i],&r[i]);
            sum *= p[i];
        }
        for (int i = 1; i <= n; i++)
        {
            ans += crt(i,sum);
        }
        ans = ans % sum;
        printf("Case %d: %lld\n",first,ans);

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值