进阶并查集问题分析

最近在一次训练中偶然做到了一道并查集的问题,刚拿到题目的时候一直在并查集还是线段树之间徘徊,最终也没有解决,于是决定再好好学习一下并查集的用法。


参考了几个很好的博客:

经典问题食物链的详解

HDU3038的讲解


让我对于并查集的应用有了更深入的理解,现在把自己的一些思路做一个总结:

这两篇博客主要讲述了如何用向量的偏移量来解决并查集中关系种类以及节点取值的问题,用根节点与子节点的关系,通过向量的和与差来表示在查找和和合并过程中子节点与父节点,每一个节点的值的变化规律,使得并查集计算节点值简化了许多,之前一直使用并查集都是维护节点之间的类属关系,接触这道题之后又发现了并查集在维护节点值的巨大作用,不得不感叹大牛们对于算法的理解。


附上我遇到的这道并查集题目:

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9470    Accepted Submission(s): 3450


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

Output
A single line with a integer denotes how many answers are wrong.
 

Sample Input
  
  
10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 

Sample Output
  
  
1


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#include <map>
#include <set>
#include <vector>
#include <queue>

using namespace std;

int fa[200005], sum[200005];

void init(int n)
{
    for(int i = 0; i <= n; ++i)
        fa[i] = i, sum[i] = 0;
    return;
}

int find(int x)
{
    if(x == fa[x]) return x;
    int tmp = find(fa[x]);
    sum[x] += sum[fa[x]];
    return fa[x] = tmp;
}

int main()
{
    int n, m;
    while(~scanf("%d%d", &n, &m))
    {
        init(n);
        int a, b, s;
        int ans = 0;
        while(m--)
        {
            scanf("%d%d%d", &a, &b, &s);
            a -= 1;
            int ra = find(a);
            int rb = find(b);
            if(ra != rb)
            {
                fa[rb] = ra;
                sum[rb] = sum[a] - sum[b] + s;
            }
            else
            {
                if(sum[b] - sum[a] != s)
                    ans += 1;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值