POJ 3617 Best Cow Line(贪心)


Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5946 Accepted: 1922

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

题的意思:1.给定长度为N的字符串S,要构造一个长度为N的字符串T。起初,T是一个空串,随后反复进行下面两个操作:1.从S的头部删除一个字符,加到T的尾部。2.从S的尾部删除一个字符,加到T的尾部。求你任意采取这两个步骤后能得到的最小字符串T

 

从字典序的性质上看,无论末尾有多大,只要前面的较小就可以,所以可以试一下贪心算法;

1. 不断地取S的开头和结尾中较小的一个字符放到T的末尾;

    这个算法已经接近正确的了,只是针对s的开头和结尾相同的没有定义,这种情况下我们希望能够今早使用较小的字符,所以比较下一字符的大小,下下一字符也可能相  同,    因此算法如下:

2. 按照字典序比较S和S反转后S';

3. 如果S较小,就从S开头取出一个字符,追加到T的末尾;

4.如果S‘较小,就从S末尾取出一个字符,追加到T的末尾;(如果相同,去哪个都一样)

 

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

#define max 2100     //切记没有“ ;”号

char str[max];
int n;

void func()
{
 int a=0,b=n-1,count=0;
 while(a<=b)
 {
   bool left=false;
   for(int i=0;a+i<=b;i++)
   { 
    if(str[a+i]<str[b-i]){left=true;break;}
    else if(str[a+i]>str[b-i])break;
   }
   if(left)putchar(str[a++]);
   else putchar(str[b--]);
   count++;
   if(count==80)putchar('\n'),count=0;
 }
 putchar('\n');//换行
}

int main()
{
 while(~scanf("%d",&n))
 {
   for(int i=0;i<n;i++) cin>>str[i];
   str[n]='\0';
   func();
 }
return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值