NYOJ 287 Radar

Radar

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1


解题思路做这种题最重要的就是转化,把圆形,矩形等问题转化为区间问题求解


此题意思给定点集S={(xi,yi)i=1.2.3...n},求用圆心在x轴上,半径为d的圆覆盖S所需的圆的最少个数。
先把给出的岛的坐标(xi.yi)和半径r转化为在x轴上的区间,
圆心位于x轴上的区间为Ii=[ xi-sqrt(d^2-yi^2) , xi + sqrt( d^2 - yi^2 )],
则转化为区间选点问题。

PS:注意是double型;

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
const int MAXN=1010;
using namespace std;
struct Node
{
double x,y;
}a[MAXN];
bool cmp(Node a,Node b){return a.x<b.x;}
int main()
{
  int n,count=1;
  double d;
  while(~scanf("%d%lf",&n,&d)&&(n!=0&&d!=0))
  {int sum=1;
   for(int i=0;i<n;i++)
   {
     scanf("%lf%lf",&a[i].x,&a[i].y);
     if(a[i].y>d)sum=-1;        
   }
   if(sum==1)
   {
    for(int i=0;i<n;i++)
    {
    double g=a[i].x;
    double f=a[i].y;
    a[i].x=g-sqrt(d*d-f*f);        
    a[i].y=g+sqrt(d*d-f*f);               
    }                            
    sort(a,a+n,cmp);
    for(int i=1;i<n;i++)
    {
     if(a[i].x>a[i-1].y)sum++;        
     else a[i].y=min(a[i].y,a[i-1].y);     
    } 
   }                         
   printf("Case %d: %d\n",count++,sum);                                                    
  }    
   system("pause");
   return 0; 
    
    
    
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值