HDOJ 1142 A Walk Through the Forest(最短路径)

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5821    Accepted Submission(s): 2151


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
  
  
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
  
  
2 4


题目大意:

给你一个图,找最短路。但是有个非一般的的条件:如果a,b之间有路,且你选择要走这条路,那么必须保证a到终点的所有路都小于b到终点的一条路。问满足这样的路径条数 有多少。。。就这个条件,看懂的时候估计都个把小时了。。。。英语不好的后果抓狂


解题思路:

1.1为起点,2为终点,因为要走ab路时,必须保证那个条件,所以从终点开始使用单源最短路Dijkstra算法,就得到了最短的一条路,作为找路的最低限度。

2.然后深搜每条路,看看满足题意的路径有多少条。当然,这个需要从起点开始搜,因为dis[i]数组中保存的都是该点到终点的最短距离。

3.这样搜索之后,dp[1]就是从起点到终点所有满足题意的路径的条数。


DFS+Dijkstra(邻接矩阵) 
#include<cstdio>  
#include<cmath>  
#include<cstring>  
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  
  
#define MAX 1000000  
#define N 1010    
int num, road, map[N][N], dis[N], dp[N];  
bool visit[N];    
void Dijkstra(int start)  
{  
    int temp, k;  
    memset(visit, 0, sizeof(visit));  
    for(int i = 1; i <= num; ++i)  
        dis[i] = map[start][i];  
    dis[start] = 0;  
    visit[start] = 1;  
    for(int i = 1; i <= num; ++i)  
    {  
        temp = MAX;  
        for(int j = 1; j <= num; ++j)  
            if(!visit[j] && temp > dis[j])  
                temp = dis[k = j];  
        if(temp == MAX) break;  
        visit[k] = 1;  
        for(int j = 1;j <= num; ++j)    
                dis[j] =min(dis[j], dis[k] + map[k][j]);  
    }  
}  
  
int DFS(int v)  
{  
    int sum = 0;  
    if(dp[v] != -1) return dp[v];  
    if(v == 2)  return 1;  
    for(int i = 1; i <= num; ++i) //v到i有路且v到终点距离大于i到终点的距离  
        if(map[v][i] != MAX && dis[v] > dis[i])  
            sum += DFS(i);//路径条数累加  
    dp[v] = sum;  
    return dp[v]; //找到的所有路径的结果  
}  
  
int main()  
{  
    //freopen("Input.txt", "r", stdin);  
    int x, y, cost;  
    while(scanf("%d", &num) != EOF && num)  
    {  
        scanf("%d", &road);  
        for(int i = 1; i <= num; ++i)  
        {  
            dp[i] = -1;  
            for(int j = 1; j <= num; ++j)  
                map[i][j] =(i==j? 0:MAX);  
        }  
        for(int i = 1; i <= road; ++i)        //邻接矩阵 
        {  
            scanf("%d%d%d", &x, &y, &cost);  
            map[x][y] = map[y][x] = cost;  
        }  
        Dijkstra(2); //终点开始最短路  
        printf("%d\n", DFS(1)); //起点深搜,得到满足题意路径条数  
    }  
    return 0;  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值