hdu-1251 字典树公共前缀。

Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
 
题意整理:
先输入一连串单词,再输入某个前缀,输出含有该前缀的单词的数目。

解题思路:
这是一道典型的字典树题,在套用字典树的模版的同时,加入一个统计经过该结点的单词的数目的变量。只要输出这个值即可。

关于字典树的一些东西:
typedef struct node{
node *next[26];   // 表示这个节点后面的字母有没有取到,0到25分别表示a到z
bool isword; // 判断这个到这个节点为止是否组成单词,本题中并没有用到这个变量
int sub; // 求字典树公共前缀数目时要用到,记录经过这个节点的单词的数目,即字树的数量
node(){
sub = 0;
for(int i = 0; i < 26; i ++)
next[i] = NULL;
} // 节点的默认构造函数
};

至于算法,可以参考这个链接:http://blog.csdn.net/topcoder1234/article/details/5887653
和百度百科:http://baike.baidu.com/view/2759664.htm?fr=aladdin


字典树图片示例:


AC代码:

#include <iostream>
#include <stdio.h>

using namespace std;

typedef struct node{
    node *next[26];
    bool isword;
    int sub;
    node(){
        isword = false;
        sub = 0;
        for(int i = 0; i < 26; i ++)
            next[i] = NULL;
    }
};

class Trie{
public:
    node *root;
    Trie(){
        root = NULL;
    }
    void insert(char str[])
    {
        if(!root)
            root = new node;
        node *location = root;
        for(int i = 0; i < strlen(str); i ++)
        {
            int num = str[i] - 'a';
            if(location->next[num] == NULL)
                location->next[num] = new node;
            location->next[num]->sub ++;
            location = location->next[num];
        }
        location->isword = true;
        
    }
    int search(char str[])
    {
        node *location = root;
        int num;
        for(int i = 0; i < strlen(str); i ++)
        {
            num = str[i] - 'a';
            if(location->next[num] == NULL)
                return 0;
            location = location->next[num];
        }
        return location->sub;
    }
};

int main()
{
    Trie tree;
    char str[15];


    while(gets(str) && strlen(str))
    {
        tree.insert(str);
    }

    while(gets(str))
    {
        int count = tree.search(str);
        cout << count << endl;
    }

    return 0;
}

当前水平难度评价: 4
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值