hdu-1022 栈的应用。

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
  
  
3 123 321 3 123 312
 

Sample Output
  
  
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
题意描述:
大意是一堆火车进栈,给出进栈的顺序和出栈的顺序,判断此出栈的顺序能否实现,若能,则输出火车进出的过程。
=。= 是一道简单的栈的应用题,但有一点要注意的是,每次有火车可以出栈时,都要记得请栈,把可以出栈的火车先出栈,再继续往后判断,特别要注意12342 24321这样的测试数据。算是一道水题。
AC代码:
#include <iostream>
#include <stack>
#include <string>
#include <vector>

using namespace std;

int main()
{
    int n;
    string o1, o2;
    stack<int> state;
    vector<string> str;
    int flag;

    while(cin >> n)
    {
        cin >> o1 >> o2;
        while(!state.empty())
            state.pop();
        str.clear();
        flag = 1;
        int i = 0, j = 0;
        for(i = 0, j = 0; i < o1.size(); i ++)
        {
            if(o1[i] == o2[j])
            {
                str.push_back("in");
                str.push_back("out");
                j ++;
                if(!state.empty())
                {
                    while(!state.empty() && state.top() + 48 == o2[j])
                    {
                        j ++;
                        str.push_back("out");
                        state.pop();
                    }
                }
            }
            else
            {
                state.push(o1[i] - 48);
                str.push_back("in");
            }
        }
        if(state.empty())
            flag = 1;
        else
        {
            while(!state.empty())
            {
                if(state.top() + 48 == o2[j])
                {
                    str.push_back("out");
                    j ++;
                    state.pop();
                }
                else
                {
                    flag = 0;
                    break;
                }
            }
        }
        if(flag)
        {
            cout << "Yes." << endl;
            for(int k = 0; k < str.size(); k ++)
                cout << str[k] << endl;
            cout << "FINISH" << endl;
        }
        else
        {
            cout << "No." << endl;
            cout << "FINISH" << endl;
        }
    }

    return 0;
}

难度评价: 3.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值