Dragon Balls

 

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 502    Accepted Submission(s): 222

 
Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it\\\\\\\'s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities\\\\\\\' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
Output

            For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

 

合并顺序是确定的,问题在于移动次数的处理。每次移动的是根节点,移动后将根节点的移动次数置为1,下次查找在压缩路径的过程中会重新计算移动次数。

 

#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN = 10000 + 10;
int p[MAXN], move[MAXN], weight[MAXN];  //move移动次数,weight龙珠个数 
int n, q;
void init(){
	for(int i = 1; i <= n; i++){
		p[i] = i;
		move[i] = 0;
		weight[i] = 1;
	}
}
void link(int x, int y){
	p[x] = y;
	weight[y] += weight[x];
}
int findfa(int x){
	move[x]++;
	if(x != p[x]) {
		return findfa(p[x]);
	}
	return p[x];
}
int find(int x){
	if(x != p[x]){
		int temp = p[x];
		p[x] = find(p[x]);
		move[x] += move[temp];	//此处计算移动次数,父节点的移动次数加上自身的移动次数 
	}
	return p[x];
}
void join(int x, int y){
	int fa = find(x);
	link(fa, find(y));
	move[fa] = 1;  //注意find(y)并未移动 
}
int main(){
	int t;
	char f;
	int a, b;
	scanf("%d", &t);
	for(int kase = 1; kase <= t; kase++){
	
		printf("Case %d:\n", kase);
		scanf("%d%d", &n, &q);
		init();
		for(int i = 0; i < q; i++){
			scanf(" %c", &f);
		if(f == 'T'){
			scanf("%d%d", &a, &b);
			join(a, b);
		}
		else if(f == 'Q'){
			scanf("%d", &a);
			int fa = find(a);  //查找时重新计算了龙珠移动次数 
			printf("%d %d %d\n", fa, weight[fa], move[a]);
		}

		}
			
	}
	return 1;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值