poj 1948 Triangular Pastures 二维01背包

Triangular Pastures
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5788 Accepted: 1854

Description

Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite. 

I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length. 

Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments. 

Input

* Line 1: A single integer N 

* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique. 

Output

A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed. 

Sample Input

5
1
1
3
3
4

Sample Output

692

Hint

[which is 100x the area of an equilateral triangle with side length 4] 

Source


#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
using namespace std;

const int maxn=888;

int dp[maxn][maxn];

int area(int x,int y,int z)
{
    double p=(x+y+z)/2.0;
    return int(sqrt(p*(p-x)*(p-y)*(p-z))*100);
}

int main()
{
    int n;
    int a[44];
    while(cin>>n)
    {
        int i,j,k;
        int sum=0,m=0;
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                sum+=a[i];
            }
        m=sum>>1;
        dp[0][0]=1;
        for(k=0;k<n;k++)
            for(i=m;i>=0;i--)
             for(j=i;j>=0;j--)
        {
            if(dp[i][j])
                dp[i+a[k]][j]=dp[i][j+a[k]]=1;
        }
        int ans=-1;
        for(i=1;i<=m;i++)
            for(j=1;j<=i;j++)
            if(dp[i][j])
            ans=max(ans,area(i,j,sum-i-j));
        cout<<ans<<endl;


    }
    return 0;
}



感觉状压也能解,只要两次01背包出最接近sum/3的,弱弱水平有限。。写不出来,还是我想错了orz,感觉二维01背包耗时又费空间。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值