HDU 4961 Boring Sum

Boring Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 114    Accepted Submission(s): 59


Problem Description
Number theory is interesting, while this problem is boring.

Here is the problem. Given an integer sequence a 1, a 2, …, a n, let S(i) = {j|1<=j<i, and a j is a multiple of a i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a f(i). Similarly, let T(i) = {j|i<j<=n, and a j is a multiple of a i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c i as a g(i). The boring sum of this sequence is defined as b 1 * c 1 + b 2 * c 2 + … + b n * c n.

Given an integer sequence, your task is to calculate its boring sum.
 

Input
The input contains multiple test cases.

Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a 1, a 2, …, a n (1<= a i<=100000).

The input is terminated by n = 0.
 

Output
Output the answer in a line.
 

Sample Input
  
  
5 1 4 2 3 9 0
 

Sample Output
  
  
136
Hint
In the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.
 

Source
 


两数相乘会爆int WA了一发。。类型转换下就好了。。


#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <fstream>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <list>
#include <stdexcept>
#include <functional>
#include <utility>
#include <ctime>

using namespace std;

#define PB push_back
#define MP make_pair
#define CLR(vis) memset(vis,0,sizeof(vis))
#define MST(vis,pos) memset(vis,pos,sizeof(vis))
#define MAX3(a,b,c) max(a,max(b,c))
#define MAX4(a,b,c,d) max(max(a,b),max(c,d))
#define MIN3(a,b,c) min(a,min(b,c))
#define MIN4(a,b,c,d) min(min(a,b),min(c,d))
#define PI acos(-1.0)
#define INF 0x7FFFFFFF
#define LINF 1000000000000000000LL
#define eps 1e-8

typedef long long ll;
typedef unsigned long long ull;


const int maxn=100000+100;
int a[maxn];
int f[maxn];
int g[maxn];

struct node{
    int vis;
    vector<int> id;
}e[maxn];


int main()
{
    int n;
    while(cin>>n && n)
    {
        CLR(e);
        int max_val=-1;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            max_val=max(max_val,a[i]);
            if(e[a[i]].vis==0) e[a[i]].id.clear();
            e[a[i]].vis=1;
            e[a[i]].id.PB(i);
        }
        int min_id,max_id;
        for(int i=1;i<=n;i++)
        {
            min_id=INF,max_id=-1;
            int ans=a[i];
            while(ans<=max_val)
            {
                if(e[ans].vis==1)
                {
                    for(int j=0;j<e[ans].id.size();j++)
                    {
                        int id=e[ans].id[j];
                        if(id<i && id>=1)
                           max_id=max(max_id,id);
                        if(id>i && id<=n)
                           min_id=min(min_id,id);
                    }
                }
                ans+=a[i];
            }
            if(max_id!=-1)   f[i]=max_id;
            else             f[i]=i;
            if(min_id!=INF)  g[i]=min_id;
            else             g[i]=i;
        }
        ll sum=0;
        for(int i=1;i<=n;i++)
            sum+=(ll)a[f[i]]*a[g[i]];
        cout<<sum<<endl;


    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值