HDU 5012 Dice bfs

Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 701    Accepted Submission(s): 396


Problem Description
There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b 1.b 2,b 3,b 4,b 5,b 6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a i ≠ a j and b i ≠ b j for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, a i ≠ b i). Ddy wants to make the two dices look the same from all directions(which means for all i, a i = b i) only by the following four rotation operations.(Please read the picture for more information)


Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line consists of six integers a 1,a 2,a 3,a 4,a 5,a 6, representing the numbers on dice A. 

The second line consists of six integers b 1,b 2,b 3,b 4,b 5,b 6, representing the numbers on dice B.
 

Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
 

Sample Input
  
  
1 2 3 4 5 6 1 2 3 4 5 6 1 2 3 4 5 6 1 2 5 6 4 3 1 2 3 4 5 6 1 4 2 5 3 6
 

Sample Output
  
  
0 3 -1
 

Source
 


#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <bitset>

using namespace std;

#define PB push_back
#define MP make_pair
#define REP(i,n) for(int i=0;i<(n);++i)
#define FOR(i,l,h) for(int i=(l);i<=(h);++i)
#define DWN(i,h,l) for(int i=(h);i>=(l);--i)
#define CLR(vis,pos) memset(vis,pos,sizeof(vis))
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LINF 1000000000000000000LL
#define eps 1e-8

typedef long long ll;

struct Dice{
    int num[6];
    int step;
};

bool vis[7][7][7][7][7][7];

void turnLeft(Dice &now,Dice &next){
    next.step=now.step+1;
    next.num[2]=now.num[0];next.num[0]=now.num[3];next.num[3]=now.num[1];next.num[1]=now.num[2];
    next.num[4]=now.num[4];next.num[5]=now.num[5];
}

void turnRight(Dice &now,Dice &next){
    next.step=now.step+1;
    next.num[0]=now.num[2];next.num[2]=now.num[1];next.num[1]=now.num[3];next.num[3]=now.num[0];
    next.num[4]=now.num[4];next.num[5]=now.num[5];
}

void turnUp(Dice &now,Dice &next){
    next.step=now.step+1;
    next.num[1]=now.num[4];next.num[4]=now.num[0];next.num[0]=now.num[5];next.num[5]=now.num[1];
    next.num[2]=now.num[2];next.num[3]=now.num[3];
}

void turnDown(Dice &now,Dice &next){
    next.step=now.step+1;
    next.num[4]=now.num[1];next.num[1]=now.num[5];next.num[5]=now.num[0];next.num[0]=now.num[4];
    next.num[2]=now.num[2];next.num[3]=now.num[3];
}

bool check(Dice a,Dice b)
{
    REP(i,6)
     if(a.num[i]!=b.num[i])
        return false;
    return true;
}

bool judge(Dice next){
    if(vis[ next.num[0] ][ next.num[1] ][ next.num[2] ][ next.num[3] ][ next.num[4] ][ next.num[5] ]==0)
      return true;
    return false;
}

queue<Dice> q;

int bfs(Dice s,Dice t){
    while(!q.empty()) q.pop();
    Dice now,next;
    q.push(s);
    vis[ s.num[0] ][ s.num[1] ][ s.num[2] ][ s.num[3] ][ s.num[4] ][ s.num[6] ]=1;
    while(!q.empty()){
        now=q.front();
        q.pop();
        if(check(now,t)) return now.step;
        turnLeft(now,next);
        if(judge(next)){
            vis[ next.num[0] ][ next.num[1] ][ next.num[2] ][ next.num[3] ][ next.num[4] ][ next.num[5] ]=1;
            q.push(next);
        }
        turnRight(now,next);
        if(judge(next)){
            vis[ next.num[0] ][ next.num[1] ][ next.num[2] ][ next.num[3] ][ next.num[4] ][ next.num[5] ]=1;
            q.push(next);
        }
        turnDown(now,next);
        if(judge(next)){
            vis[ next.num[0] ][ next.num[1] ][ next.num[2] ][ next.num[3] ][ next.num[4] ][ next.num[5] ]=1;
            q.push(next);
        }
        turnUp(now,next);
        if(judge(next)){
            vis[ next.num[0] ][ next.num[1] ][ next.num[2] ][ next.num[3] ][ next.num[4] ][ next.num[5] ]=1;
            q.push(next);
        }
    }
    return -1;
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    Dice s,t;
    while(scanf("%d",&s.num[0])!=EOF){
        CLR(vis,0);
        FOR(i,1,5)
          scanf("%d",&s.num[i]);
        s.step=0;
        REP(i,6)
          scanf("%d",&t.num[i]);
        t.step=-1;
        printf("%d\n",bfs(s,t));
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值