N^N次方最后一位数字的求法

Problem Description

Given a positive integer N, you should output the most right digit of N^N. 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.


Sample Input

2

3

Sample Output

7

6

#include<iostream>
using namespace std;

int main()
{
	int a[10][2] ={{0},{1},{4,6},{7,3},{6},{5},{6},{3,7},{6,4},{9}};//每个不同数字的N次方的结果的可能性列举
	int rows,tmp;
	cin>>rows;
	int *arr = new int[rows];
	for(int i = 0;i<rows;i++)
		cin>>arr[i];
	for(int i = 0;i<rows;i++)
	{
		tmp = arr[i]%10;
		switch(tmp)
		{
		case 0:
			cout<<a[0][0]<<endl;
			break;
		case 1:
			cout<<a[1][0]<<endl;
			break;
		case 2:
			{
				if((arr[i]-tmp)%20 == 0)//减去结尾数字求得除以20的余数是否为0
					cout<<a[2][0]<<endl;
				else
					cout<<a[2][1]<<endl;
				break;
			}
		case 3:
			{
				if((arr[i]-tmp)%20 == 0)
					cout<<a[3][0]<<endl;
				else
					cout<<a[3][1]<<endl;
				break;
			}
		case 4:
			cout<<a[4][0]<<endl;
			break;
		case 5:
			cout<<a[5][0]<<endl;
			break;
		case 6:
			cout<<a[6][0]<<endl;
			break;
		case 7:
			{
				if((arr[i]-tmp)%20 == 0)
					cout<<a[7][0]<<endl;
				else
					cout<<a[7][1]<<endl;
				break;
			}
		case 8:
			{
				if((arr[i]-tmp)%20 == 0)
					cout<<a[8][0]<<endl;
				else
					cout<<a[8][1]<<endl;
				break;
			}
		case 9:
			cout<<a[9][0]<<endl;
			break;
		}
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值