G - Problem G-求n的n次方结果最右边数字

Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

大致意思:给定一个正整数N,您应该输出N^N这一最右边的数字

我的见解:数字很大,所以用longlongint 看起来是挺简单的,但用常规方法一做就会超出时间限制,因为循环太久了,所以用一开始超出时间的代码来找规律 尾数是0和1的显然多少次方后仍保持不变,然后就试2的 2,12,22,32,42,52等等就可以得到规律了。

代码如下

#include <iostream>
using namespace std;


int main()
{
	int t;
	long long int n, k;
	cin >> t;
	while (t)
	{
		t--;
		cin >> n;
		k = n % 10;
		if (k == 0 || k == 1 || k == 5 || k == 6 || k == 9)
		{
			cout << k << endl;
			continue;
		}
		if(k==4)
		{
			cout << (k + 2) << endl;
			continue;
		}
		if (k == 2)
		{
			if ((((n - 2) / 10) % 2) == 0)cout << (k + 2) << endl;
			else cout << (k + 4) << endl;
			continue;
		}
		if (k == 3)
		{
			if ((((n - 3) / 10) % 2) == 0)cout << (k + 4) << endl;
			else cout << k << endl;
			continue;
		}
		if (k == 7)
		{
			if ((((n - 7) / 10) % 2) == 0)cout << (k-4) << endl;
			else cout << k << endl;
			continue;
		}
		if (k == 8)
		{
			if ((((n - 8) / 10) % 2) == 0)cout << (k - 2) << endl;
			else cout << (k - 4) << endl;
			continue;
		}
	}
}

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wujiekd

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值