hdu 3350 #define is unsafe

http://acm.split.hdu.edu.cn/showproblem.php?pid=3350

#define is unsafe

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 494    Accepted Submission(s): 306


Problem Description
Have you used #define in C/C++ code like the code below?

#include <stdio.h>
#define MAX(a , b) ((a) > (b) ? (a) : (b))
int main()
{
  printf("%d\n" , MAX(2 + 3 , 4));
  return 0;
}

Run the code and get an output: 5, right?
You may think it is equal to this code:

#include <stdio.h>
int max(a , b) {  return ((a) > (b) ? (a) : (b));  }
int main()
{
  printf("%d\n" , max(2 + 3 , 4));
  return 0;
}

But they aren't.Though they do produce the same anwser , they work in two different ways.
The first code, just replace the MAX(2 + 3 , 4) with ((2 + 3) > (4) ? (2 + 3) : 4), which calculates (2 + 3) twice.
While the second calculates (2 + 3) first, and send the value (5 , 4) to function max(a , b) , which calculates (2 + 3) only once.

What about MAX( MAX(1+2,2) , 3 ) ?
Remember "replace".
First replace: MAX( (1 + 2) > 2 ? (1 + 2) : 2 , 3)
Second replace: ( ( ( 1 + 2 ) > 2 ? ( 1 + 2 ) : 2 ) > 3 ? ( ( 1 + 2 ) > 2 ? ( 1 + 2 ) : 2 ) : 3).
The code may calculate the same expression many times like ( 1 + 2 ) above.
So #define isn't good.In this problem,I'll give you some strings, tell me the result and how many additions(加法) are computed.
 

Input
The first line is an integer T(T<=40) indicating case number.
The next T lines each has a string(no longer than 1000), with MAX(a,b), digits, '+' only(Yes, there're no other characters).
In MAX(a,b), a and b may be a string with MAX(c,d), digits, '+'.See the sample and things will be clearer.
 

Output
For each case, output two integers in a line separated by a single space.Integers in output won't exceed 1000000.
 

Sample Input
  
  
6 MAX(1,0) 1+MAX(1,0) MAX(2+1,3) MAX(4,2+2) MAX(1+1,2)+MAX(2,3) MAX(MAX(1+2,3),MAX(4+5+6,MAX(7+8,9)))+MAX(10,MAX(MAX(11,12),13))
 

Sample Output
  
  
1 0 2 1 3 1 4 2 5 2 28 14
 

Author
madfrog





#include<bits/stdc++.h>
using namespace std;
typedef long long int ll;
const int inf = 0x7fffffff;
#define ms(x) memset((x),0,sizeof(x))


char s[1005];
int pos,cnt;
int dfs(int &f0){
    int a[2] = {}; int flag = 0; int f[2]={};
    for(;s[pos]!=0;pos++){
        if(  s[pos] == '(' ){
            pos++; a[flag] += dfs( f[flag] );
        }
        else if( s[pos] == ')' ) {break;}
        else if( s[pos] == ',' ) flag++;
        else if( s[pos]>='0'&&s[pos]<='9' ){
            int temp = 0;
            while(s[pos]>='0'&&s[pos]<='9'){
                temp = temp*10+s[pos]-'0';
                pos++;
            }
            pos--; a[flag] += temp;
        }
        else if( s[pos] == '+' ){
            f[flag]++;
        }
    }
    f0 += f[0]+f[1];
    if( a[0] > a[1] ) f0 += f[0];
    else f0 += f[1];
    cnt = f[0]+f[1];
    return max(a[0],a[1]);
}
int main(){
 //   freopen("1.txt","r",stdin);
    int n;  scanf("%d",&n); getchar();
    while(n--){
        scanf("%s",s);
        int f[2] = {}; pos=0; cnt=0;
        int ans = dfs(f[0]);
        printf("%d %d\n",ans,cnt);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值