POJ----1426

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32535 Accepted: 13604 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100

111111111111111111

题意:  给出一个整数n,(1 <= n <= 200)。求出任意一个它的倍数m,要求m必须只由十进制的'0'或'1'组成。

解题思路:由题意看出只有0和1两个数字组成,(易知知道任何一个正整十进制数乘10以后,末位肯定是0,乘10以后加1,

末位就是1)就是说要得到m只有两种操作,第一种操作n*10,第二种操作是n*10+1,接下来看代码。

#include<stdio.h>

#include<queue>

using namespace std;

int n;

void bfs()

{

    queue<longlong> q;

   q.push(1);

    while(!q.empty())

    {

       long long int t=q.front()//拿出队首元素;

       q.pop();//出队

       if(t%n==0) //每出队一个数,判断是否是n的倍数,是就输出t,返回

       {

           printf("%lld\n",t);

           return ;

       }

       q.push(t*10); //操作1

       q.push(t*10+1);//操作2

    }

}

int main()

{

    while(~scanf("%d",&n)&&n)

    {

       bfs();

    }

    return0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值