九度oj1439n个数最大公倍数

题目1439:Least Common Multiple

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:406

解决:135

题目描述:

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入:

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出:

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入:
2
3 5 7 15
6 4 10296 936 1287 792 1
样例输出:
105
10296

 

#include<stdio.h> 
#define max(a,b) (((a) > (b)) ? (a) : (b)) 
int main() 
{ 
    int instances, m; 
    long long number, n; 
      
    while(scanf("%d", &instances) == 1) 
    { 
        for(int k = 0; k < instances; k++) 
        { 
            scanf("%d%lld", &m, &number); 
            for(int i = 1; i < m; i++) 
            { 
                scanf("%lld", &n); 
                for(long long j = max( number, n); j <= number * n; j += max( number, n))//如果题目要求只能用int数,那么把所有数都改成int型,然后这里的number*n改成0x80000000即可,不然会溢出 
                    if( (j % number == 0) && (j % n == 0) ) 
                    { 
                        number = j; 
                        break; 
                    } 
            } 
            printf("%lld\n", number); 
        } 
    } 
    return 0; 
} 
  
/************************************************************** 
    Problem: 1439 
    User: true14fans 
    Language: C 
    Result: Accepted 
    Time:0 ms 
    Memory:912 kb 
****************************************************************/


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值