VJudge River Hopscotch(二分查找解最小值最大)

 

VJudge River Hopscotch(二分查找解最小值最大)

描述

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M  Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

 

题意

一条河长L,中间有N块石头,绝对距离已给。要求移除M块石头后石头与石头之间距离最小值最大结果。

思路

典型的二分查找求最小值最大/最大值最小问题,设初始上下界为L,0,mid为假设的最小距离。

读入所有数据,sort排序所有石头的绝对距离

遍历所有石头,判断两块石头之间距离是否小于最小值,若小于,移除一块石头,移除数量+1,继续判断下一块石头;若大于等于,将距离的头更新为当前判断石头。直至遍历结束。之后将移除石头的数量与题目给出的M比较,若移除数大于M,说明假设的距离太大了,应让right=mid-1;反之,假设的距离可能正好是答案,可能太小,不管怎样,先用变量ans记录当前mid防止答案丢失,再让left=mid+1。直至left>right

注意

数据L过大,某些变量应定义为long long型

别忘了ans存mid的值

两端也有石头,绝对距离分别为0和L,但这两块不能移除,故不记录在数组

代码

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    long long a[50005];
    long long l;
    int n,m;
    scanf("%lld %d %d",&l,&n,&m);
    for(int i=0;i<n;i++)
    {
        scanf("%lld",&a[i]);
    }
    sort(a,a+n);
    long long Left=0,Right=l,mid,ans=0;
    long long nowStone=0;
    int sum=0;
    while(Left<=Right)
    {
        nowStone=0;
        sum=0;
        mid=(Left+Right)/2;
        for(int i=0;i<n;i++)
        {
            if(a[i]-nowStone>=mid) nowStone=a[i];
            else sum++;
        }
        if(l-nowStone<mid) sum++;
        if(sum<=m)
        {
            ans=mid;
            Left=mid+1;
        }
        else Right=mid-1;
    }
    printf("%lld",ans);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值