poj2456 贪心+二分

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9
Sample Output
3
Hint
OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

题目大意是让牛之间的间距最大化,即最大化最小值(同样最小化最大值也用二分)。

#include <cstdio>
#include <cmath>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
ll a[100005];
int n,c;
bool judge(ll x)
{
   int sum=1;
   ll k=a[0];
   for(int i=1;i<n;i++){
    if(a[i]-k>=x)
    {
        k=a[i];
        sum++;
        if(sum>=c)
            return true;
    }
   }
   return false;
}
void solve()
{
    ll right=a[n-1],left=0,mid;
    while(right>=left){//二分法要注意1.循化出口的条件,否则会死循环 2.选择左边好是右边的问题;
        mid=(left+right)/2;
        if(judge(mid))
            left=mid+1;
        else
            right=mid-1;
    }
    cout<<left-1<<endl;
}
int main()
{
    scanf("%d %d",&n,&c);
      for(int i=0;i<n;i++)
        scanf("%ld",&a[i]);//一定要用scanf,否则100000的数量级会超时
            sort(a,a+n);//贪心要想到排序。
        solve();
   
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值