UVA714 二分最小化最大值+贪心处理输出

Copying Books
Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu
Submit

Status

Description

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so calledscribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you havem books (numbered ) that may have different number of pages ( ) and you want to make one copy of each of them. Your task is to divide these books among k scribes, . Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, . At the second line, there are integers separated by spaces. All these values are positive and less than 10000000.

Output
For each case, print exactly one line. The line must contain the input succession divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/’) to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input
2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100
Sample Output
100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

题意:给定m个数,划分为k组数,使得每组数之和的最大值最小,如果有多种解,输出第一组尽量小的解,如果仍有多组解,第二组应尽量小

分析:对于最大化或者最小化的最值问题,明显逝去用二分去解决,这里就不在赘述,这里要说的是输出的问题
因为分配的情况有多种,因此题目要求输出最小的情况,也就是样例二的那一种情况的处理,如何处理呢?可以这样去处理,先将所有的数据从后往前去遍历一遍,首先由二分得到的答案最大值在这里设为maxv,然后再从后往前遍历一遍,每次将所得到的数据相加,直到相加的结果是大于maxv时,此时就是说明能够分出一组,那么将所求的和归零,并标记此时需要输出‘/’,然后继续重复,直到遍历到头;
如果到最后还是有一个’/‘没有得到标记,那么就从前往后遍历,找到第一个没有标记的,然后标记为在此输出’/’,这样就能保证,前面的划分最多;

#include <cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
#define rep(i,a,b) for(int i=a;i<=b;i++)
const int maxn = 0x3f3f3f3f;
const int N=1e6+10;
int n,m;
ll a[N];
int ans[N];
bool Ok(ll p){
    int k=0;
    int i=0;
    while(i<n){
        ll sum=0;
        while(sum+a[i]<=p&&i<n) sum+=a[i],i++;
        k++;
        if(k>m) return false;
//        i++;
    }
    return k<=m;
}
int main(){
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    int t;
    scanf("%d",&t);
    while(t--){
        memset(ans,0,sizeof ans);
        scanf("%d%d",&n,&m);
        ll ub =0,lb=0;
        rep(i,0,n-1) scanf("%lld",&a[i]),ub+=a[i];
        ub++;
        while(ub-lb>1){
            ll mid=(ub+lb)>>1;
            if(Ok(mid)) ub=mid;
            else  lb=mid;
        }
        ll sum=0;
        for(int i=n-1;i>=0;i--){
            sum+=a[i];
            if(sum>ub){
                sum=0;
                ans[++i]=1;
                m--;
            }
        }
        int i=1;
        while(m>1){
            for(;i<n;i++){
                if(!ans[i]){
                    ans[i]=1;
                    m--;
                    break;
                }
            }
        }
        printf("%lld",a[0]);
        for(int i=1;i<n;i++){
            if(ans[i]) printf(" /");
            printf(" %lld",a[i]);
        }
        printf("\n");
    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值