zzuli2183: 就是签到题XD(欧拉常数)

传送门->点我

Description

In mathematics, we suppose that f(1)=1, f(i)-f(i-1)=1/i, (2<=i<=n)

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case starts with a line containing an integer n (2 ≤ n ≤10^7).

Output

For each case, print the case number and the value of f(n). The answer should be rounded to 10 decimal places.

Sample Input

3234

Sample Output

Case 1: 1.5000000000Case 2: 1.8333333333Case 3: 2.0833333333
题意:求f(n)=1/1+1/2+1/3+1/4…1/n,精确小数点后10位

知识点:

     调和级数(即f(n))至今没有一个完全正确的公式,但欧拉给出过一个近似公式:(n很大时)

      f(n)ln(n)+C+1/2*n    

      欧拉常数值:C≈0.57721566490153286060651209

      c++ math库中,log即为ln。

但是n很小是直接求

贴代码:


#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define maxn 10000011
double r = 0.57721566490153286060651209;
double a[10005];
int main()
{
    a[1] = 1;
    for(int i=2; i<=10000; i++)
        a[i] = a[i-1] + 1.0/i;
    int t;
    scanf("%d",&t);
    for (int cas=1; cas<=t; cas++)
    {
        int n;
        scanf("%d",&n);
        if(n <= 10000)
            printf("Case %d: %.10lf\n",cas,a[n]);
        else
        {
            double sum;
            sum = log(n) + r + 1.0/(2*n);
            printf("Case %d: %.10lf\n",cas,sum);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值