河南省多校连萌(五)【zzuli 2183 就是签到题XD】

点击打开链接


2183: 就是签到题XD

Time Limit: 1 Sec   Memory Limit: 64 MB
Submit: 525   Solved: 79

Submit Status Web Board

Description

In mathematics, we suppose that f(1)=1, f(i)-f(i-1)=1/i, (2<=i<=n)

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case starts with a line containing an integer n (2 ≤ n ≤10^7).

Output

For each case, print the case number and the value of f(n). The answer should be rounded to 10 decimal places.

Sample Input

3234

Sample Output

Case 1: 1.5000000000Case 2: 1.8333333333Case 3: 2.0833333333

HINT

Source

河南省多校连萌(五)




题解:f(i)=1/1+1/2+1/3+1/4+...+1/i;分段打表即可求解(64MB<10e7*8),不然会出现内存超限。。。



#include<cstdio>
#define Max 10000005
double temp[Max/100];
void init()
{
	double s=0,q=1;
	for(int i=1;i<Max;i++)
	{
		s+=q/(double)i; 
		if(i%100==0)
			temp[i/100]=s;
	}
	return ;
}
int main()
{
	double ans;
	int n,a;
	init();
	while(~scanf("%d",&n)) 
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a);
			ans=temp[a/100];
			for(int j=a/100*100+1;j<=a;j++)
				ans+=(double)1/j;
			printf("Case %d: %.10lf\n",i,ans);
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值