【nyoj715】Adjacent Bit Counts

Description

For a string of n bits x1, x2, x3, …, xn,  the adjacent bit count of the string  is given by     fun(x) = x1*x2 + x2*x3 + x3*x 4 + … + xn-1*x n
which counts the number of times a 1 bit is adjacent to another 1 bit. For example: 
     Fun(011101101) = 3
     Fun(111101101) = 4
     Fun (010101010) = 0
Write a program which takes as input integers n and p and returns the number of bit strings x of n bits (out of 2ⁿ) that satisfy  Fun(x) = p.

For example, for 5 bit strings, there are 6 ways of getting fun(x) = 2:
11100, 01110, 00111, 10111, 11101, 11011

Input

On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10  Each case is a single line that contains  a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (p) giving the desired adjacent bit count. 1 ≤ n , p ≤ 100

Output

For each test case, output a line with the number of n-bit strings with adjacent bit count equal to p.

Sample Input

2
5 2
20 8

Sample Output

6
63426


题意:给n,p,代表01串的长度是n,运算后是p,运算规则为x1*x2 + x2*x3 + x3*x4 + … + xn-1*xn,求这样的01串共有几个。


思路:dp[i][j][k]代表01串长度为i,运算结果是j,最后一位数是k。所以最终答案是dp[n][p][0]+dp[n][p][1].

转移方程dp[i][j][0]=dp[i-1][j][0]+dp[i-1][j][1],dp[i][j][1]=dp[i-1][j][0]+dp[i-1][j-1][1].根据n p范围,所以有:

i:2~n

j:1~p

循环想好后注意初始化,当i=1时,考虑到dp[1][0][1]=1,dp[1][0][0] = 1;

但是还存在一组特殊情况:j等于0,dp[i][0][0]=dp[i-1][0][0]+dp[i-1][0][1];dp[i][0][1]=dp[i-1][0][0];


代码:

#include<bits/stdc++.h>
using namespace std;
#define N 102
#define LL long long
int dp[N][N][2];
int main()
{
    int j, k, n, t, i, p;
    dp[1][0][1] = 1;
    dp[1][0][0] = 1;
    for(i = 2; i <= 100; i++)
    {
        dp[i][0][0]=dp[i-1][0][0]+dp[i-1][0][1];
        dp[i][0][1]=dp[i-1][0][0];
    }
    for(i = 2; i <= 100; i++)
        for(j = 1; j <= 100; j++)
            for(k = 0; k < 2; k++)
                if(k == 0) dp[i][j][k] = dp[i-1][j][0]+dp[i-1][j][1];
                else dp[i][j][k] = dp[i-1][j-1][1]+dp[i-1][j][0];
    while(t--)
    {
        cin>>n>>p;
        cout<<dp[n][p][1]+dp[n][p][0]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值