Adjacent Bit Counts

题目描述

For a string of n bits x1, x2, x3, …, xn,  the adjacent bit count of the string  is given by     fun(x) = x1*x2 + x2*x3 + x3*x 4 + … + xn-1*x n
which counts the number of times a 1 bit is adjacent to another 1 bit. For example: 
     Fun(011101101) = 3
     Fun(111101101) = 4
     Fun (010101010) = 0
Write a program which takes as input integers n and p and returns the number of bit strings x of n bits (out of 2ⁿ) that satisfy  Fun(x) = p.

For example, for 5 bit strings, there are 6 ways of getting fun(x) = 2:
11100, 01110, 00111, 10111, 11101, 11011

输入

On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10  Each case is a single line that contains  a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (p) giving the desired adjacent bit count. 1 ≤ n , p ≤ 100

输出

For each test case, output a line with the number of n-bit strings with adjacent bit count equal to p.

样例输入

2
5 2
20 8

样例输出

6
63426



对于长度为i的串假设它的权值为j,则长度为i+1,的串的权值只可能是j或j+1,只与长度为i的字符串的末位和新加的字符串有关,

令 dp[i][j][k] 表示长度为 i 的串、权值为 j 、末位为 k (0 or 1) 的方案种数。

状态转移方程为 dp[i][j][0] = dp[i-1][j][0] + dp[i-1][j][1] , dp[i][j][1] = dp[i-1][j][0] + dp[i-1][j-1][1]。

    #include<stdio.h>  
    #include<string.h>  
    int dp[105][105][2];  
    int main()  
    {  
        int t,i,j;  
        scanf("%d",&t);  
        dp[1][0][0]=dp[1][0][1]=1;  
        for(i=2;i<105;i++)  
        {  
            dp[i][0][0]=dp[i-1][0][0]+dp[i-1][0][1];  
            dp[i][0][1]=dp[i-1][0][0];  
            for(j=1;j<i;j++)  
            {  
                dp[i][j][0]=dp[i-1][j][0]+dp[i-1][j][1];  
                dp[i][j][1]=dp[i-1][j-1][1]+dp[i-1][j][0];  
            }  
        }  
        while(t--)  
        {  
            int n,p;  
            scanf("%d%d",&n,&p);  
            printf("%d\n",dp[n][p][0]+dp[n][p][1]);  
        }  
    }  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值