zoj 3175 Number of Containers (大数灵活题,除2改成平方根)

91 篇文章 2 订阅
4 篇文章 0 订阅

For two integers m and kk is said to be a container of m if k is divisible by m. Given 2 positive integers n and m (m < n), the function f(nm) is defined to be the number of containers of m which are also no greater than n. For example, f(5, 1)=4, f(8, 2)=3, f(7, 3)=1, f(5, 4)=0...

Let us define another function F(n) by the following equation: 


Now given a positive integer  n , you are supposed to calculate the value of F( n ).

Input

There are multiple test cases. The first line of input contains an integer T(T<=200) indicating the number of test cases. Then Ttest cases follow.

Each test case contains a positive integer n (0 < n <= 2000000000) in a single line.

Output

For each test case, output the result F(n) in a single line.

Sample Input

2
1
4

Sample Output

0

4

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3216

本质就是求(n/1+n/2+...+n/n-1)-n的值

数字太大,不能用n/2,只能用平方根(这个在比赛的时候完全想不到。。)

推导过程:比如 n=10

=1*10

=2*5

=3*3

10-5=5,5-3=2

然后我们又惊奇地发现最后的结果10,5,3,2,2,1,1,1,1,1

1有5个,2有2个,于是找到规律。

但是对于像8这样的数字来说,还有两个数字没有赋值到,于是sum+=未赋值个数*当前的b

其他方法:http://blog.csdn.net/zxy_snow/article/details/6159956

#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<set>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define mod 1000000007
#define ll long long
#define sd(x) scanf("%d",&x)
#define sd2(x,y) scanf("%d%d",&x,&y)
#define fr1(x) freopen("1.txt","r",stdin)
#define fr2(x) freopen("2.txt","w",stdout)
using namespace std;
int main(){
    int t,cnt=0;
    cin>>t;
    while(t--){
    	ll n,s=0;
    	cin>>n;
    	ll p=0;
    	for(int i=1;i*i<=n;++i){
    		s+=n/i-1;
    		s+=p*(n/i-n/(i+1));
    		if(n/i-1<=p)
    			s-=p*(n/i-n/(i+1));
    		p++;
    	}
    	cout<<s<<endl;
    }
    return 0;
}

int main(){
	int t;
	cin>>t;
	while(t--){
		ll n;
		cin>>n;
		ll s=0;
		ll a=n,b=1,c=1;
		for(ll i=2;i*i<=n;++i){
			s+=n/i+(a-n/i)*b;
			c+=a-(n/i)+1;
			b++;
			a=n/i;
		}
		s+=(n-c)*b;
		cout<<s<<endl;
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值