ZOJ.3175 Number of Containers【数学问题】 2015/10/11

Number of Containers

Time Limit: 1 Second      Memory Limit: 32768 KB

For two integers m and k, k is said to be a container of m if k is divisible by m. Given 2 positive integers n and m (m < n), the function f(n, m) is defined to be the number of containers of m which are also no greater than n. For example, f(5, 1)=4, f(8, 2)=3, f(7, 3)=1, f(5, 4)=0...

Let us define another function F(n) by the following equation:


Now given a positive integer n, you are supposed to calculate the value of F( n).

Input

There are multiple test cases. The first line of input contains an integer T(T<=200) indicating the number of test cases. Then T test cases follow.

Each test case contains a positive integer n (0 < n <= 2000000000) in a single line.

Output

For each test case, output the result F(n) in a single line.

Sample Input

2
1
4

Sample Output

0
4


Author: CAO, Peng
Source: The 9th Zhejiang University Programming Contest

有点摸不着头脑,不是很懂(。・∀・)ノ゙

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int main(){
    long long n,ans,t,i;
    cin>>t;
    while(t--){
        cin>>n;
        ans = 0;
        for( i = 1 ; i*i <= n ; ++i ){
            ans += n/i;
        }
        ans *= 2;
        i--;
        ans = ans - i*i-n;
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值