hdu4190 n个城市,m个投票箱。求票数最大的投票箱内票数最少时的数目

样例输入:

2 7
200000
500000

4 6
120
2680
3400
200

-1 -1

样例输出:

100000
1700
有n个城市,m个投票箱。每个城市的人口分别是xi。求票数最大的投票箱内票数最少时的数目。

思路:尽量均分。

【二分版】

#include <iostream>
#include <iomanip>
#include <fstream>
#include <sstream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <algorithm>
#include <functional>
#include <numeric>
#include <string>
#include <set>
#include <map>
#include <stack>
#include <vector>
#include <queue>
#include <deque>
#include <list>
using namespace std;
typedef long long ll;


int a[500000+100];
bool cmp(int a, int b)
{
	return a>b;
}
int main()
{
	int n,b;
	while(scanf("%d%d",&n,&b),n!=-1)
	{
		int l=0,r=0;
		for(int i=0 ; i<n ; ++i)
		{
			scanf("%d",&a[i]);
		}
		sort(a,a+n,cmp);
		r=a[0];
		while(l<r)
		{
			int mid=(l+r)/2;
			int k=0;
			for(int i=0 ; i<n ; ++i)
			{
				if(a[i]<=mid)
				{
					k++;
					continue;
				}
				int t=a[i]/mid;
				if(a[i]%mid)
					t++;
				k+=t;
			}
			if(k<=b)
			{
				r=mid;
			}
			else
			{
				l=mid+1;
			}
		}
		printf("%d\n",l);
	}
}
【优先队列版】
#include<iostream>    
#include<algorithm>    
#include<string>    
#include<map>   
#include<vector> 
#include<queue> 
#include<cmath>    
#include<string.h>    
#include<stdlib.h>    
#include<cstdio>    
#define ll long long  
#define mod 10000
using namespace std; 
struct node{
	int a,b,c; //当前城市值,盒子数
}x[500005];
struct cmp{  
   bool operator()(const node &t1,const node &t2){  
        return t1.a<t2.a;  //从大到小,与数组规则相反   
   }  
};  
int main(){
	priority_queue<node,vector<node>,cmp> q;
	int n,m;
	while(cin>>n>>m){
		if(n==-1&&m==-1)
			break;
		while(!q.empty())
			q.pop();
		for(int i=0;i<n;++i){
			cin>>x[i].a;
			x[i].b=1;
			x[i].c=x[i].a;
			q.push(x[i]);
		}
		int maxx=0;
		for(int i=0;i<m-n;++i){
			node fr=q.top();
			q.pop();
			fr.b++;
			fr.a=fr.c/fr.b;
			if(fr.c%fr.b!=0)
				fr.a++;
			q.push(fr);
		}
		node fr=q.top();
		cout<<fr.a<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,关于 HDU4992 所有原根的问题,我可以给出以下解答: 1. 首先,我们需要知道什么是原根。原根是指模 n 意义下,所有与 n 互质的数 a 的最小正整数 k 次幂对 n 取模的值覆盖了所有与 n 互质的数。简单来说,就是如果一个数 a 是模 n 意义下的原根,那么 a 的任何正整数次幂对 n 取模的值都不相同,且能覆盖所有与 n 互质的数。 2. 为了模 n 意义下的所有原根,我们需要先出与 n 互质的数的个数 phi(n)。phi(n) 可以使用欧拉函数出。 3. 然后,我们需要枚举模 n 意义下的所有数,判断它是否是原根。具体来说,对于每个 a,我们需要判断 a 的每个小于 phi(n) 的正整数次幂对 n 取模的值是否都不相同,且能覆盖所有与 n 互质的数。如果是,那么 a 就是模 n 意义下的原根。 4. 代码实现可以参考以下 Java 代码: ``` import java.util.*; public class Main { static int gcd(int a, int b) { return b == 0 ? a : gcd(b, a % b); } static int phi(int n) { int res = n; for (int i = 2; i * i <= n; i++) { if (n % i == 0) { res = res / i * (i - 1); while (n % i == 0) { n /= i; } } } if (n > 1) { res = res / n * (n - 1); } return res; } static int pow(int a, int b, int mod) { int res = 1; while (b > 0) { if ((b & 1) != 0) { res = res * a % mod; } a = a * a % mod; b >>= 1; } return res; } static boolean check(int a, int n, int phi) { for (int i = 1, j = pow(a, i, n); i <= phi; i++, j = j * a % n) { if (j == 1) { return false; } } return true; } public static void main(String[] args) { Scanner scanner = new Scanner(System.in); while (scanner.hasNext()) { int n = scanner.nextInt(); int phi = phi(n); List<Integer> ans = new ArrayList<>(); for (int i = 1; i < n; i++) { if (gcd(i, n) == 1 && check(i, n, phi)) { ans.add(i); } } Collections.sort(ans); for (int x : ans) { System.out.print(x + " "); } System.out.println(); } } } ``` 其中,gcd 函数用于最大公约数,phi 函数用于欧拉函数,pow 函数用于快速幂模,check 函数用于判断一个数是否是原根。在主函数中,我们依次读入每个 n,出 phi(n),然后枚举模 n 意义下的所有数,判断它是否是原根,将所有原根存入一个 List 中,最后排序输出即可。 希望我的回答能够帮到你,如果你有任何问题,欢迎随提出。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值