hdu 2852 KiKi's K-Number(树状数组)

KiKi's K-Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2645    Accepted Submission(s): 1218


Problem Description
For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?
 

Input
Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.
 

Output
For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".
 

Sample Input
  
  
5 0 5 1 2 0 6 2 3 2 2 8 1 7 0 2 0 2 0 4 2 1 1 2 1 2 2 1 3 2 1 4
 

Sample Output
  
  
No Elment! 6 Not Find! 2 2 4 Not Find!
 
树状数组的区间求和,逗比了,wa了两发,以为数组值为0,这个元素才不存在,其实不一定,应该前a个元素与a-1个和相同。


代码
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
const int maxn=100000+100;
int a[maxn+10];
int low(int k)
{
    return k&(-k);
}
void update(int k,int v)
{
    while(k<maxn)
    {
        a[k]+=v;
        k+=low(k);
    }
}
long long getsum(int k)
{
    long long ans=0;
    while(k>0)
    {
        ans+=a[k];
        k-=low(k);
    }
    return ans;
}
int find(int a,int k)
{
    long long temp=getsum(a);
    int l=a+1;
    int r=maxn;
    int mid;
    if(k>(getsum(maxn)-temp))
    return -1;
    while(l<r)
    {
        mid=(l+r)>>1;
        long long t;
        t=getsum(mid)-temp;
        if(k>t)
        {
            l=mid+1;
        }
        else
        {
            r=mid;
        }
    }
    return l;
}
int main()
{
    int m;
    while(~scanf("%d",&m))
    {
        int order,x,y;
        memset(a,0,sizeof(a));
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&order);
            if(order==0)
            {
                scanf("%d",&x);
                update(x,1);
            }
            if(order==1)
            {
                scanf("%d",&x);
                if(getsum(x)-getsum(x-1)==0)//坑死了
                {
                    printf("No Elment!\n");
                }
                else
                {
                    update(x,-1);
                }
            }
            if(order==2)
            {
                scanf("%d%d",&x,&y);
                int p=find(x,y);
                if(p==-1)
                printf("Not Find!\n");
                else
                printf("%d\n",p);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值