hdu 2852 KiKi's K-Number (树状数组+二分)

Problem Description

For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?

Input

Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.

Output

For each deletion, if you want to delete the element which does not exist, the output “No Elment!”. For each query, output the suitable answers in line .if the number does not exist, the output “Not Find!”.

Sample Input

5
0 5
1 2
0 6
2 3 2
2 8 1
7
0 2
0 2
0 4
2 1 1
2 1 2
2 1 3
2 1 4

Sample Output

No Elment!
6
Not Find!
2
2
4
Not Find!

分析:

开mark数组标记每个数字出现的次数
树状数组c维护区间内数字个数
第一个操作直接修改mark和c
第二个操作直接判断mark是否为0和修改c
第三个操作二分第k大的位置用树状数组判断c[mid]-c[x]是否大于等于k找出答案

code:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;
const int maxm=1e5+5;
int c[maxm];
int mark[maxm];
void init(){
    memset(c,0,sizeof c);
    memset(mark,0,sizeof mark);
}
int lowbit(int i){
    return i&-i;
}
void add(int i,int t){
    while(i<maxm){
        c[i]+=t;
        i+=lowbit(i);
    }
}
int ask(int i){
    int sum=0;
    while(i){
        sum+=c[i];
        i-=lowbit(i);
    }
    return sum;
}
int ffind(int x,int y){
    int l=x,r=1e5;
    int ans=-1;
    while(l<=r){
        int mid=(l+r)/2;
        if(ask(mid)-ask(x)>=y){
            ans=mid;
            r=mid-1;
        }else{
            l=mid+1;
        }
    }
    return ans;
}
signed main(){
    int m;
    while(scanf("%d",&m)!=EOF){
        init();
        while(m--){
            int d;
            scanf("%d",&d);
            if(d==0){
                int x;
                scanf("%d",&x);
                add(x,1);
                mark[x]++;
            }else if(d==1){
                int x;
                scanf("%d",&x);
                if(!mark[x]){
                    puts("No Elment!");
                }else{
                    mark[x]--;
                    add(x,-1);
                }
            }else{//d==2
                int x,y;
                scanf("%d%d",&x,&y);
                int ans;
                if(x+y>100000||(ans=ffind(x,y))==-1){
                    puts("Not Find!");
                }else{
                    printf("%d\n",ans);
                }
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值